Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently rebuilt my machine to Windows 7 x64, installed Sql Server 2008 enterprise. I can connect fine to other remote instances via Management Studio (be they 2000, 2005 or 2008), but i cannot find my local default instance.

  • I have verified that a directory was created for the default instance C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER
  • I can connect to SQLEXPRESS instance fine
  • I have rerun setup to ensure I have everything installed
  • I have verified that the SQLSERVER(MSSQLSERVER) service is running
  • I have verified that SQL Server Browser is running
  • I have tried brownsing for the instance and see all the others available except my local one
  • I have tried using this for servername: TSOUTHERLANDPC\MSSQLSERVER, the first part being my local machine name

My issue is not the same as this post or this post.

Any ideas?

share|improve this question
    
cant figure out how to post another answer even tho I have enough reputation... but would like to offer my resolution –  Mike Trader Nov 9 '11 at 6:23

5 Answers 5

up vote 3 down vote accepted

re-install sql server. I had the same problem and then noticed that instead of installing a local instance I installed a named instance ( that just so happened to be the same name as a local instance). For some reason there is a difference between a local instance with the exact same name as a local instance and when you actually choose local instance.

share|improve this answer
    
seriously? ugg.. There is no way to setup a default instance if you chose named instance during install? And I very well could have done as it's been a few weeks since I installed. –  Tone May 14 '10 at 21:00
    
You can do another install, if there is no default instance already installed, you will have an option to add a default instance. Once you get things straightened out, just disable the service for the named instance. –  SqlACID May 14 '10 at 22:09
    
i uninstalled just sql server, and reinstalled selecting the default instance but still get same thing, guess my next step is to uninstall every last bit of it. I am running Win7 x64 and installed SQL server x64. –  Tone May 15 '10 at 2:22
    
i uninstalled completely and reinstalled but the Developer edition this time (still R2). I think I chose enterprise the first time around b/c I didn't feel like downloading the developer edition from msdn. works fine now. thanks! –  Tone May 16 '10 at 2:11

Try your hostname followed by the instancename, for instance PC\SQLEXPRESS

share|improve this answer
    
Right I've tried that. SQLEXPRESS works fine, but MSSQLSERVER, which is the default instance, does not. –  Tone May 15 '10 at 16:50
    
I tried MYMACHINE\LOCAL and got in finally. Running developer version of 2008 R2. Thanks for the suggestion. –  user70163 Feb 9 '11 at 19:15
    
Perfect. Thanks! What hand to forehead moment. –  Jeff Jun 5 '12 at 19:44

Check the configuration manager and make sure the browser is running.

share|improve this answer
    
SQL Server Browser is running. –  Tone May 14 '10 at 19:03

The instance name that you should use for the default instance is the hostname of your machine, so try just tsoutherlandpc and see if that does it for you.

share|improve this answer
    
I get login failed when I try that. I'm using windows auth. –  Tone May 14 '10 at 21:01
    
after a complete reinstall, and using the developer edition this time, this approach works. –  Tone May 16 '10 at 2:10

As stupid as this sounds, open SQL Management Studio by using Right Click -> Run As Administrator.

You should now be able to connect to your default instance.

This is a wonderfully undocumented 'feature' that occurs on any of the newer Windows OS' with UAC enabled.

share|improve this answer
    
+1 - This worked for me. –  Andreas Ågren Jul 1 '11 at 14:27

protected by Iain Aug 12 '11 at 17:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.