Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The only way I've found of resizing the "Change Journal" in Vista, is by going to safe-mode. That works fine, but I wonder if there is a better solution.

Here is resizing it from 32MB by default on my HDD to 256MB with 1MB increments:

fsutil usn deletejournal /D /N c:
fsutil usn createjournal m=268435456 a=1048576 c:
fsutil usn queryjournal c:

The code above if executed normally won't do anything (and it worked on XP). It also worked for my Vista's machine D: drive, but not C:

And the code would work once you boot in Safe mode + Command Promprt (hint: press F8 at boot and select it).

I guess the reason is some Windows Service, and usually that would be the old Indexing one, but I don't have it enabled. What others might be causing it?

share|improve this question

3 Answers 3

The fsutil doc pages say that you must run fsutil as administrator, which would explain the behavior you're seeing.

share|improve this answer

By default on Windows 2000, 2003, XP an NTFS volume will have its Change Journal disabled. A service on an application (usually backup software) must explicitly activate the journal.

On Vista and Windows 2008, the Change Journal is active by default. Any application can activate or disable the volume's journal at any time but note that on Vista and Windows 2008, if the Change Journal is deactivated, it is automatically reactivated by the system.

Safe mode should (and apparently does) allow you to change the journal. As far as which services use the journal; indexing, VSS, block level backup, link tracking,antivirus software are all likely candidates. I would also guess that the new autorepair functionality uses it as well. I'd hesitate to change the journal size (especially increasing it). The change Journal is a sparse file and is purged as needed. HTe journal will grow beyhond whatever size you set automatically then purge it back down (from Creating, Modifying, and Deleting a Change Journal:

MaximumSize is the target maximum size for the change journal in bytes. The change journal can grow larger than this value, but at NTFS file system checkpoints the NTFS file system examines the journal and trims it when its size exceeds the value of MaximumSize plus the value of AllocationDelta. (At NTFS file system checkpoints, the operating system writes records to the NTFS file system log file that allow the NTFS file system to determine what processing is required to recover from a failure.)

share|improve this answer

You might try running in an elevated command prompt. Find Command Prompt in the start menu, and right-click then Run As Administrator. Agree to allow the program to run in Elevated Privileges.

Try running the command then.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.