Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My VM becomes sluggish after a few hours (~12 hours or so) of being idle, there is no impact on the host, just the guest. The guest OS becomes sluggish.

It has lots of RAM, runs on RAID 0, quad core i5 750, everything is defragmented, but the only way I found to keep its responsiveness optimal is to shutdown (dumps the memory) and the start; a restart of the guest OS doesn't dump the memory so I need to be able to do a stop of the VM, and then a start.

Coming from Hyper-V I had to learn VMware and after a few months of fine tunning it I'm quite impressed with how configurable VMware is. This is the only small issue I haven't been able to fix, has anyone encountered this?

[EDIT]

Thanks for pointing out those features Helvik, here are my current settings.

Advanced Default/Default

  • Gather debugging information: None
  • Disable memory page trimming: Unchecked
  • Log virtual machine progress periodically: Unchecked
  • Enable template mode: Unchecked

Replay section Debugging enabled

  • Maximum disk: Unlimited
  • Save the last: Unlimited
  • Snapshot frequency: Never
  • Enable VAssert (experimental): Unchecked
  • Enable Visual Studio debugger (experimental): Checked

I have no snapshots. It does have Visual Studio installed. I see 3 log files were created earlier today (248 KB each). Would you recommended I change some settings?

[2nd EDIT]

Thanks, I have now disabled the Visual Studio debugging feature.

Host

  • OS: Windows 7 x64
  • Processor: Intel Core i5 750 (quad core, no hyperthreading)
  • Mem: 4 GB
  • Drives: 4x500 GB in RAID 0
  • 1 DVD drive

Guest

  • OS: Windows 2008 R2
  • Processor: 1 CPU
  • Mem: 2 GB
  • Drives: 1 Drive 18/140 GB used, full disk space is not pre-allocated
  • 1 DVD drive
  • 1 floppy drive
  • USB controller is present, nothing is using USB on the guest, and only keyboard and mouse are using USB on the host.

So far the things I have done are:

  1. Disable Visual Studio debugging

  2. The DVD drive on the guest was mapped to a DVD drive letter that didn't exist anymore on the host, I now changed it to the correct drive letter.

  3. I have changed this setting from 'some' to 'most' in VMware Workstation's: Preferences>Memory>Allow most virtual machine memory to be swapped. When it was set to 'some', I could see from the task manager on the host, that the VM was using the whole 2 GB it's allowed to use, although Task Manager on the guest showed it was using only 500 MB. Now with this setting set to 'most' Task Manager on the guest shows the VM uses about 500 MB of its 2 GB of RAM, and Task Manager on the guest also matches that.

I will let it run for a good 12 hours and then check the VM's responsiveness.

share|improve this question

closed as off topic by SvW, mdpc, John Gardeniers, Khaled, Ward Feb 17 '13 at 4:45

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
ok, I just found the answer to the no GUI question here serverfault.com/questions/89029/… vmrun -T ws start C:\export\vmware\rh5\server.vmx nogui I could not find this command line option anywhere, serverfault.com is definetly a great resource. I will edit my question to expose the idle VM performance issue incase someone else has encountered this. My host is win 7 x64 and the guest 2008 r2 x64 –  GenEric35 May 15 '10 at 15:03
    
Do you have VM Logging enabled? Under VM Settings, Options, Advanced what settings are enabled for debugging info, memory page trimming & VM progress logging? Under The Replay section is anything enabled? Do you have any snapshots active? –  Helvick May 15 '10 at 21:06
    
Hi, thanks for answering, Advanced Default/Default -Gather debugging information: None -Disable memory page trimming: Unchecked -Log virtual machine progress periodically: Unchecked -Enable template mode: Unchecked Replay section Debugging enabled -Maximum disk: Unlimited -Save the last: Unlimited -Snapshot frequency: Never -Enable VAssert(experimental): Unchecked -Enable Visual Studio debugger(experimental): Checked I have no snapshots. It does have visual studio installed. I see 3 log files were created earlier today(248 KB each). Would you recommended I change some settings? –  GenEric35 May 16 '10 at 0:34
    
You could try disabling the Visual Studio Debugger to see if thats leaking something over an extended period but that's really just a guess, the other settings are OK. Can you post your Guest\Host OS details and the specific config of the VM vs the Host (amount of RAM and number of CPU's, what peripheral devices are configured like USB). –  Helvick May 16 '10 at 8:24
    
Thanks Helvick, I have updated the my question with Host vs Guest configuration, and disabled VMWare's visual studio debugging experimental feature. I'll let it run for a good 12-24 hours at idle to see if the changes had a positive effect. –  GenEric35 May 16 '10 at 14:19

4 Answers 4

in vmware ws, go to Edit > Preferences > Memory tab > Fit All virtual Machine into reserve host ram > OK

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable if you described how/why this is an answer. Thank you and welcome to Server Fault! –  Chris S Feb 15 '13 at 16:13
1  
This is the same as Massimo's answer. It should just be a comment below his citing that it is the steps to take. –  TheCleaner Feb 15 '13 at 16:25

If you're saying the VM becomes sluggish and not the host, then troubleshoot the VM as you would if it were physical. My guess offhand is that it's nothing to do with the host / VMware. With that being said, since your host is 2008 r2, try firing up the resource monitor and checking out things like disk latency, ram usage, CPU usage, etc.

share|improve this answer

If you have enough memory on the host system to comfortably fit all the virtual memory you are allocating to your VM, then you should change the memory preferences to "Fit all virtual machine memory into reserved host RAM"; this will prevent the host O.S. from swapping it out on the assumption that it's not being used.

Setting that option to "Allow most virtual machine memory to be swapped" will actually make things worse.

share|improve this answer
    
And you have to disable memory page trimming. –  Shiki Jun 22 '12 at 10:36

If you have VMware Tools installed, it could be this bug:

http://www.boche.net/blog/index.php/2010/03/28/windows-2008-r2-and-windows-7-on-vsphere/

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1011709

The symptoms are similar to what I've seen on ESX.

share|improve this answer
    
thanks for the input, I will see what can be done with the VGA drivers, but I'm not convinced it would be a VGA problem, the more information the window has to gather, the more it's affected by the slowdown, it's not like graphically complex windows or snap ins are more affected, i'd bet it's I/O(CPU?) that becomes 'constipated', but I'll look into the VGA thing –  GenEric35 May 22 '10 at 0:24
    
the driver that was installed was VMware SVGA 3D (Microsoft Corporation) from oct 17 2009, and i couldn't see the new updated driver that ESX has in common files, (I should upgrade from workstation 7.0.0 to 7.0.1) since the new driver not on my host, so I just uninstalled the current driver and logged in using remote desktop, it seems to work fine for now, i'll let it run for 12-24 hours see if it gets sluggish –  GenEric35 May 23 '10 at 15:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.