Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server, and it is running a error for one email only (all other mails in that domain are working).

How can i fix it? (The error is above:)

May 17 11:43:56 webserver postfix/policyd-weight[5596]: weighted check:  IN_DYN_PBL_SPAMHAUS=3.25 NOT_IN_SBL_XBL_SPAMHAUS=-1.5 NOT_IN_SPAMCOP=-1.5 NOT_IN_BL_NJABL=-1.5 DSBL_ORG=ERR(0) CL_IP_NE_HELO=4.75 RESOLVED_IP_IS_NOT_HELO=1.5 HELO_NUMERIC=10.625 (check from: .eticagest. - helo: .[10.0.0.17]. - helo-domain: .17].)  FROM_NOT_FAILED_HELO(DOMAIN)=6.25; <client=xxx.xxx.xxx.xxx> <helo=[10.0.0.17]> <from=MAIL@CLIENTDOMAIN.com> <to=ME@MYDOMAIN.com>; rate: 21.875 
May 17 11:43:56 webserver postfix/policyd-weight[5596]: decided action=550 Mail appeared to be SPAM or forged. Ask your Mail/DNS-Administrator to correct HELO and DNS MX settings or to get removed from DNSBLs; MTA helo: [10.0.0.17], MTA hostname: bl15-139-211.dsl.telepac.ptxxx.xxx.xxx.xxx] (helo/hostname mismatch); <client=188.80.139.211> <helo=[10.0.0.17]> <from=MAIL@CLIENTDOMAIN.com> <to=ME@MYDOMAIN.com>; delay: 6s 
share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

The client doesn't had authentication on the SMTP Server. For some strage reason, it gaves this error.

Thanks all for the answers ;)

share|improve this answer
add comment

The client 188.80.139.211 sent EHLO 10.0.0.17 or HELO 10.0.0.17 as a greeting to your mail server. According to RFC 2821 (section 4.1.1.1) the client should send its FQDN or (if none available) an address literal (e. g. its IP address).

So the correct greeting would be EHLO bl15-139-211.dsl.telepac.pt (or another valid FQDN pointing to the client) or EHLO 188.80.139.211 if no meaningful hostname is available but definitely not EHLO 10.0.0.17.

Since the error occurs because of a misconfiguration of the client, you could only put the client on a whitelist to always accept its mails.

share|improve this answer
    
This client is using thunderbird, what can i do to corrent that? –  CuSS May 17 '10 at 13:46
    
I think the problem is that SMTP client isn't authenticating, i will confirm that –  CuSS May 17 '10 at 13:51
    
OK, the problem was on the SMTP Authenticating, the client wasn't authenticating. Thanks for your full answer. Your answer didn't solve my problem, but i will give +1 for the simpaty and details in the answer ;) (Here on Server Fault i can't vote up yet :( but when i can, i will vote ;) ) –  CuSS May 17 '10 at 14:33
add comment

Try setting:

myhostname = host.example.com

in main.cf

share|improve this answer
    
that didn't solve, but thanks for your answer ;) –  CuSS May 17 '10 at 14:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.