Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to set up Firefox to run as limited user in admin account using DropMyRights (Firefox 3, Windows XP Pro, SP3). I had it working fine for a while, then it starting failing. Firefox process starts and immediately exits when run under DropMyRights. Works fine when I go back to the standard shortcut launch. Anyone with DropMyRights experience, what should I try to figure out what the problem is??

share|improve this question

Are you using DropMyRights to drop you down to Standard User, or to drop you all the way down to a Low Rights User?

On Windows Vista i tried running Firefox as a limited user (i.e. even lower than standard user) by setting it to run at the low integrity level:

icacls firefox.exe /setintegritylevel Low 

Firefox then fails on startup:

alt text

Perhaps that's what changed with your usage of DropMyRights, are you now dropping it too low? Firefox does not react well to being a limited user - and the concensus is that it never will support "Protected Mode", like Chrome and IE do.

Older Answer

i've not used DropMyRights on FireFox, but...

i did see a case where the FireFox shortcut was triggering an elevation (UAC) prompt; whereas running the executable itself would not trigger an elevation prompt. Somehow the shortcut was marked as require administrator - which is not possible through any UI in Windows.

Deleting and recreating the shortcut fixed it, and the user no longer has to elevate to run FireFox when running from a shortcut.

Perhaps deleting your shortcut, and recreating.

My other suggestion is to use Process Explorer, and see what the problem is.

Filter it to only show FireFox.exe, and hopefully you will see some ACCESS_DENIED messages before it vanishes.

share|improve this answer
That's because some installer-generated shortcuts are special shortcuts that work through MSI which is why they sometimes show "Please wait, configuring xyz". When you recreate your shortcut it directly executes the Application EXE. – Jarvis May 30 '09 at 7:15
The shortcut pointed to Firefox.exe directly. Does that make sense? – Ian Boyd Jun 2 '09 at 14:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.