Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a strange situation with apache2. Meanless, random 403 errors. Any page (html, php etc.) normally working. but if i request repeatedly by pressing refresh button of browser. it interrupts & sends a 403 randomly. after a few seconds it works again. in the error log, i see client denied by server configuration.
main error log of apache says
[info] server seems busy, (you may need to increase StartServers, or Min/MaxSpareServers), spawning 8 children, there are 99 idle, and 137 total children

my current values
IfModule mpm_prefork_module StartServers 120 MinSpareServers 100 MaxSpareServers 200 MaxClients 256 MaxRequestsPerChild 500 /IfModule

i've increased 10 by 10. from 20. but nothing solved. i've disabled KeepAlive.

What may cause this problem ?
thank you in advance.


a fresh install Ubuntu server x86 8.04.4
Virtualmin from it's website (not from debian repositories).
Linux 2.6.24-27-server #1 SMP i686 - Apache 2.2.8 Mpm prefork
Virtualmin version 3.78.gpl GPL
PHP Version 5.2.4-2ubuntu5.10
Loaded modules:
core_module (static) log_config_module (static) logio_module (static) mpm_prefork_module (static) http_module (static) so_module (static) actions_module shared) alias_module (shared) auth_basic_module (shared) auth_digest_module (shared) uthn_file_module (shared) authz_default_module (shared) authz_groupfile_module (shared) uthz_host_module (shared) authz_user_module (shared) autoindex_module (shared) ache_module shared) cgi_module (shared) deflate_module (shared) dir_module (shared) env_module (shared) expires_module (shared) fcgid_module (shared) file_cache_module (shared) eaders_module (shared) mime_module (shared) mime_magic_module (shared) evasive20_module shared) negotiation_module (shared) php5_module (shared) rewrite_module (shared) etenvif_module (shared) ssl_module (shared) status_module (shared) Syntax OK

share|improve this question
add comment

2 Answers

Is the server under heavy load? Maybe try to enable mod_status and see what happen when you get 403.

share|improve this answer
    
there is no heavy load. i've checked many times with mod_status. but no luck. –  risyasin May 18 '10 at 5:50
add comment
up vote 0 down vote accepted

it was mod_evasive.
http dos & ddos protection module.

i couldn't think it may log as "server busy". also mod_evasive itself is not dropping any log.

any fast solution seeker like me can misunderstand the situation.

thank you again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.