Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Big problem. I have nearly given up. I am trying to port my prototype to use MS SQL so it will work on a server once i get it (the server will be SQL Server 2008, shared, i dont know any more info).

So i tried to connect to SQL Server via visual studios IDE and had no luck. I enabled TCP and named pipes and restarted the service (and computer) with still no luck.

I remembered about mdf files so i made that after an obstacle of not being able to make the connect string require i figure out visual studio has it in its properties and successfully connected with that.

Then i had a problem with nested transactions. After not being able to figure out how to check i wondered if i can configure it to allow it somehow. I always thought all of MS were the same except for limitations but sql server seems to support nested transactions so theres no point trying to work around the problem with .mdf files since i wont need them and really just used it to port the base of my sql code and to check if syntax is correct.

I tried installing SQL Server Management Studio since people mentioned it several times (as a solution or at least help). When installing it on windows 7 it says it may not be compatible. After running it, it launched SQL Server Installation Center (64-bit) which doesnt seem to be the same thing as i dont see a way to modify any of my server (networking) configurations or edit user permissions, etc.

I am clueless what to do next. Does anyone have any ideas? I'm posting here bc i think my problem is more configurations and sql server then programming.

share|improve this question
  • management studio runs fine on windows 7. The warning is because you need to apply SP1 to sql 2008.

  • all version of SQL server are the "same" however some versions are more equal than others. Express is missing some "enterprisey" features (log shipping, clustering etc). For full details look here

  • if all you have is installation manager and configuration manager it means you chose the wrong version of sql server express as 1 comes with it and another version doesn't. you can download the sql management studio for express from Microsoft seperately. You will have to reapply SP1.

  • I'm not sure what you mean by MDF files, you shouldn't be accessing mdf files directly. If sql server management studio can connect so can visual studio object explorer.

share|improve this answer
ok. so random thoughts. 1) This came from 2010(official release) so shouldnt it have all the most recent update 2) the link to install it seperately (SQLManagementStudio_x64_ENU.exe) is what i use which launch the sql server installer 3) i tried installing sp1 (SQLServer2008SP1-KB968369-x64-ENU.exe) but it has the error "There are no SQL Server Instance or shared features that can be updated on this computer.". – acidzombie24 May 19 '10 at 7:52
clicking the SQLManagementStudio_x64 will launch this I assume that isnt SQL Management Studio?. I dont access directly in the sense of File.Open. I realize there was a connectionstring in visual studio so used that. It doesnt seem to support nested transactions so i dont bother with it since it seems like my actual server will. I am still stuck and not able to create databases in code (or even in visual studios) outside of .mdf files. I havent tried SQL CE which i know i do not want (not similar to my server) – acidzombie24 May 19 '10 at 7:55

Perhaps reinstalling is a good idea? If you want to grab the SQL Server Express with Management Tools installer for SQL 2008 R2 from Microsoft and then install you will get both the Database Engine Services and the Management Tools (SQL Server Management Studio) needed.

Do you need help with a different version?

share|improve this answer
if you like, read the comment i left Jim above. – acidzombie24 May 19 '10 at 14:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.