Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I run any svn command on my Mac, I get messages like the following:

$svn help
svn: Mismatched RA version for 'neon': found 1.6.2, expected 1.6.5

$svn checkout /some/repo
svn: Mismatched RA version for 'http': found 1.6.2 expected 1.6.5

What did I do, and how do I rectify this problem?

share|improve this question

2 Answers 2

Looks like not all of your SVN client was upgraded from 1.6.2 to 1.6.5 (namely the neon package, which is a HTTP/WebDav library).

A bit of a google on this, lead me to these instructions:

Check if you have neon by running:

which neon-config

If you have neon, a path to neon-config will be outputted. Everything before /bin/neon/config is your neon home directory.

The neon version needs to be 0.25.x or greater. Check the neon version with:

neon-config --version

If you have a suitible version of neon, make a note of the neon home directory for use in the last step, Install Subversion Itself.

If you don't have neon, or need to install a newer version, get a recent copy it from the WebDAV website in a .tar.gz archive. Install it with:

cd /research/oranfry/sources
tar -xzf /path/to/neon-X.X.X.tar.gz
cd neon-X.X.X
./configure --prefix=/research/oranfry/neon make make install

Remember the neon home directory. In my case it is /research/oranfry/neon.

(your milage may vary, be careful of paths)

share|improve this answer

If you had installed the Subversion from Collabnet on your Mac, and are getting the above error, you're probably running svn installed with your Mac OS X. Try this command:

which svn

If you get /usr/bin/svn, that's the old version causing the error.

You need to add this line to ~/.bash_profile:

export PATH=/opt/subversion/bin/:$PATH

Log out, log in, and try the which command, it should point to the new version.

NOTE: The Collabnet installer says to put the export command into ~/.profile, however that doesn't seem to work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.