Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running IIS and SQL Server 2008 Express on my Windows 7 host, and I'd like to be able to connect to them in XP Mode. My host machine is not a part of a domain, only a workgroup.

So far, I've tried these instructions on connecting to SQL Server, but I'm not able to telnet to port 1433 on the host from XP Mode. I'm also not able to connect using a SQL client.

I'm not able to connect to IIS on the host from XP Mode.

Advice from those who have had success doing this would be appreciated.

Thanks,

Jon.

Update: I'm wondering if this is a simple permissions issue. I'm on a workgroup, not a domain, so I can't test/fix this simply by granting permissions in SQL Server and IIS to a domain user.

share|improve this question
    
I assume you can connect to the SQL Server from the Windows 7 host machine? –  Mark Henderson May 19 '10 at 1:18
    
Yes, I can connect on the host machine. –  SpatialBridge May 20 '10 at 13:48
add comment

2 Answers 2

up vote 1 down vote accepted

This turned out to be a permissions issue. Since I am not on a domain, I was trying to connect to the host machine from the virtual machine using a local account on the virtual machine.

To fix the problem, I modified the

The steps I used are as follows:

  1. In the virtual machine, click Start > Control Panels > Users.
  2. Click the name of the current user (or whichever user you're using to run the client apps that are connecting to the host machine).
  3. Click "Manage my Network Passwords".
  4. Click Add to open the Logon Information Properties dialog.
  5. Type the name of the host machine in the Server text box.
  6. Type the name of the appropriate host machine local account in the User name text box (\).
  7. Type the password for the host machine local account in the Password text box.
  8. Click OK > Close.

I also had to open the Windows firewall to HTTP requests to be able to access IIS.

Following this procedure, I can now access SQL Server and IIS from the XP Mode virtual machine.

share|improve this answer
    
NICE! good call. –  Campo May 20 '10 at 16:18
add comment

The end of those instructions talk about Firewalls... Did you check your firewall on the host? If it is on turn it off just to test if that's the issue. Then if it is the issue open the necessary ports. If that is not it think about if any other firewalls are between your host and client.

Hope its as simple as that. Let us know.

share|improve this answer
    
Yes, turned firewall off both on host and virtual machine. Still no go. Using Microsoft Loopback Adapter, so should be no other firewalls in play. –  SpatialBridge May 20 '10 at 13:48
    
Are you allowing remote connection for SQL? The setting is in the Management Studio. –  Campo May 20 '10 at 14:17
    
Yes, remote connections are allowed. –  SpatialBridge May 20 '10 at 14:44
    
Is it a named instance? –  Campo May 20 '10 at 15:22
    
Turned out to be a permissions issue -- see answer below. –  SpatialBridge May 20 '10 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.