Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a classic ASP website that is crashing in IIS7. It is crashing because IIS doesn't allow file uploads greater than a certain size. I know this because files below about 200k work fine. I removed the Status Code 500 error in IIS but I still don't get a file name and the line where my code failed as I do when running locally.

Instead I get:

"The page cannot be displayed because an internal server error has occurred. If you are the system administrator please click here to find out more about this error."

See http://adcore-com-au.si-sv3956.com/admin/edit_options.asp for an example.

See http://www.yart.com.au/admin/edit_options.asp for what it should look like.

How do I get a file name and the line where my code failed?

Here are my IIS settings:

alt text

share|improve this question
    
Viewing the site from the computer that's running IIS tends to show more error details (assuming the default settings). –  Chris S May 19 '10 at 2:45

1 Answer 1

up vote 4 down vote accepted

Login as an admin on the IIS server, open IIS 7 Manager, the open the Asp icon under the Web site you want to change the error messages for (it'll be on the right with all the other icons; it's the first one).

Scroll down and change Send Errors To Browser to True. Might have to iisreset, not sure.

share|improve this answer
    
After you get it working you might want to set it back to not sending errors to the browser. –  Bratch May 19 '10 at 14:50
    
Yup, Microsoft disabled error output by default so that sensitive information about your configuration (databases, IPs, paths, etc.) is not disclosed to your visitors. –  gravyface May 19 '10 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.