Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Anyone here who knows how to get the +-*/ on the numerical keypad to work in gnu screen from putty? Number work fine but not the operators. the / seems to be bind to renme the current shell or maybe start a new shell. My host os is ubuntu 9.04 ( the os i run screen on ).

Best Regards Anders Olme

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

If you set the following in your .screenrc the numpad keys will work

termcapinfo xterm ks@:ke@

I don't know if this will change any other important settings you might be using, however, so it would be worth giving things a test.

It might be that there is a better setting string, but so far I haven't been able to find one.

Update:
I've been searching around looking through termcap, terminfo, terminfo/termcap and screen manuals, but it looks like no-one is having much luck with getting both the number pad and the arrow keys in ncurses apps to work at the same time (they still seem to work in non-ncurses apps).

The closest I've seen is from these threads. Someone spoke to one of the program maintainers regarding an almost identical problem, however as of the 10th of March the problem wasn't resolved.

share|improve this answer
    
Nice it worked :). Has to see if something else breaks but hopefully not. –  Buzzzz May 29 '09 at 10:17
    
Hm buy doing so the arrow keys stopped working in midknight commander and centerim.. –  Buzzzz May 29 '09 at 10:47
    
Fixed it for me too, no issues in any apps so far. –  red Dec 27 '12 at 12:47
add comment

You can check the configuration, go to

Terminal

--> Keyboard

     --> Function keys and keypad

Choose whichever works for you. Usually, Linux / Xterm R6

share|improve this answer
    
Well it works fine if I don't use screen. Looks like screen rebinds those keys for some reason. –  Buzzzz May 29 '09 at 8:06
add comment

Another configurationthat worked for me: In Putty configuration->Terminal->Features: Put a tick in "Disable application keypad mode"

http://vim.wikia.com/wiki/PuTTY_numeric_keypad_mappings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.