Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just setup two servers running 10.04 server and have installed the ubuntu-desktop as follows:

sudo apt-get install ubuntu-desktop

The problem is even though it says it has installed it will not auto-start...

I've tried this:

sudo mv /etc/init/gdm.conf /etc/init/gdm.disabled

sudo mv /etc/init/gdm.disabled /etc/init/gdm.conf

To enable/disable it but still not joy.

Any ideas?

Thanks, Ben

EDIT

So the problem is I want to the desktop to start when the computer starts, when I setup my 8.04 server and installed ubuntu-desktop it started immediately, I've never known how to start the desktop from the command line so am out of my depth a bit.

What's the difference between GDM and X? I don't know how to tell if either has started, I mean I can run /ect/init.d/gdm start and it seems to start, but nothing really happens on screen, if I type startx the screen goes blank...

EDIT 2

I've been playing around some more and have made a discovery, I tried to install one of the identical servers from the desktop iso, but it failed to get past the first screen. A quick search on google brought up this post, I added the startup option i915.modeset=0 (or =1, i forget :D), this resolved the problem for this installation!

So I went back to the one with 10.04 server installed, sudo pico /boot/grub/grub.cfg and added the i915.modeset to the end of the boot command, and now the server boots to something vaguely visual!

Both desktop and server installations are now showing the same problem with graphics configuration problem, and I'm thinking that could be because of the intel graphics we're using.

I now get a Ubuntu is running in low-graphics mode error, I'm now going to test witha nVidia graphics card to see if this solves the problem.

EDIT 3

Thanks to everyone who helped solve my problem, I have now fixed the error... take a look at my answer to the question below.

share|improve this question
    
Gdm is a graphical login manager...X is the graphical server. If you try /etc/init.d/gdm start (or restart) which error do you see? Can you look in /var/log/syslog? –  Pier May 19 '10 at 9:39
    
It doesn't say anything in the log :S When I press ctrl + alt + F7 I get the blank screen, I can then press ctrl + alt + F6 to return back to the command line. –  Ben Everard May 19 '10 at 9:43
    
And when you start gdm, no errors? –  Pier May 19 '10 at 9:50
    
When I do sudo /etc/init.d/gdm start it says this: Rather than invoking init scripts through /etc/init.d, use the service (8) utility, e.g. service gdm start.... when I run this command it pukes out an error message, not going to type the lot but says "rejected send message"... :'( doing this on 8.04 was so easy –  Ben Everard May 19 '10 at 9:56
    
Do you use 'sudo service gdm start'? –  Pier May 19 '10 at 10:00
show 7 more comments

5 Answers

The best way to install the gnome GUI, IMO, is to use tasksel. First go to a terminal type in the following in order to see the exact name of the package "taskel --list-tasks" (without the apostraphes). This will list the tasks by the name tasksel needs. In this case we us the command "tasksel install ubuntu-desktop. There is a catch to this method that you may not want and, that catch is you will at some point end up with a generic kernel. OH! If you use any of the methods above you will also loose your server kernel. I have! Now to prevent getting the generic kernel you can us this command,

If you wan to install a graphical desktop manager without some of the desktop addons like Evolution and OpenOffice, but continue to use the server flavor kernel use the following command

sudo aptitude install --no-install-recommends ubuntu-desktop

How to install GUI in Ubuntu 10.04 (Lucid Lynx) Server

share|improve this answer
add comment

you probably want to run /etc/init.d/gdm restart or reboot your computer.

a forum discussing installation of ubuntu-desktop had these suggestions:

sudo apt-get update
sudo apt-get install ubuntu-desktop
sudo apt-get install gdm
sudo /etc/init.d/gdm start
sudo dpkg-reconfigure xserver-xorg

perhaps that will get you further? can you expand on what the exact problem is? does X start? does GDM run? what's going on.

share|improve this answer
    
Done both of these many times without success –  Ben Everard May 19 '10 at 8:09
    
what is the problem, exactly... it doesn't boot up to a GUI? you may need to change your runlevel in /etc/inittab, change id:2:initdefault: to id:3:initdefault: and then run sudo telinit 3 –  cpbills May 19 '10 at 8:15
    
Certainly don't delete your answer as it might help someone else with these symptoms. I see this as more of a server issue than anything else which is why I stuck it here. Thanks for your answer. –  Ben Everard May 19 '10 at 8:16
    
See my edited post :-) –  Ben Everard May 19 '10 at 9:28
    
i still don't quite understand you problem. to me, it sounds like the correct X driver isn't installed. and you might need to run something like apt-get install xserver-xorg-video-nv which is the name, for the nvidia X.org drivers. before you did anything, did your 'server' boot up to a command line interface/login? and what happens now, can you expand? –  cpbills May 19 '10 at 16:27
add comment

What happens after the blank screen? Do you hear your harddisk working? After the blank screen try to start with ALT+CTRL+F1. This should bring you to another console.

Login and reconfigure your display:

sudo dpkg-reconfigure xserver-xorg
share|improve this answer
    
Can you please post your system configuration? Maybe you have insufficient memory or your graphic doesn't work with ubuntu. I don't know :) –  ud. May 19 '10 at 9:46
    
Brand new build, Intel i3 530, 4GB RAM, Intel onboard graphics etc –  Ben Everard May 19 '10 at 10:16
    
Running on top of a Asrock H55M board –  Ben Everard May 19 '10 at 10:17
    
Try this please: sudo apt-get install --reinstall gdm && sudo dpkg-reconfigure gdm –  ud. May 19 '10 at 10:39
    
Have you tried another monitor? –  ud. May 19 '10 at 11:02
show 2 more comments
up vote 0 down vote accepted

I've found the solution after hours of research, thanks to everyone who has helped.

Thanks go to kras1001 on this Ubuntu Forums thread who suggested to manually set the onboard memory to 128mb, instead of automatic. I then got rid of the i915.modeset=0 in the GRUB config and now we're up and running!

Wooooohoooooo

share|improve this answer
add comment

FAIL. You don't install ubuntu-desktop on ubuntu-server. You install the display manager of your choice (gnome, kde, etc).

For example, Gnome Display Manager install on Ubuntu Server:

sudo apt-get install xorg gnome-core gdm gnome-applets gnome-system-tools gnome-utils ubuntu-artwork compiz-gnome firefox sysv-rc-conf

sudo apt-get install fast-user-switch-applet

The gdm (desktop) will start automatically when the server starts. For an even leaner setup to start the gdm, open a terminal and run:

sudo sysv-rc-conf

Look for “gdm” in the list and then uncheck (using the space bar) the X under column (runlevels) 2 and 3. Now the GUI will only start if you run:

startx

Enjoy! -Trent

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.