Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to use openssl s_client for accessing Gmail POP3S server. I am doing the following:

$ openssl s_client -connect pop.gmail.com:995
+OK Gpop ready for requests from <removed: ip> d11pf35377217wam.36
USER <removed: user@gmail.com>
+OK send PASS
PASS <removed: password>
+OK Welcome.
LIST
+OK 1 messages (2197 bytes)
1 2197
.
STAT
+OK 1 2197
RETR 1
RENEGOTIATING

The problem is I am never able to execute the RETR command. It always hangs while "RENEGOTIATING".

What am I missing?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I had a similar problem when testing an SSL connection to GMail's SMTP server.

The AUTH and MAIL FROM commands worked fine but when I tried the RCPT TO the server returned the RENEGOTIATING response.

After searching for quite a bit I finally found a site that explained what was going on.

Apparently the uppercase R at the start of the command (RCPT TO for SMTP and RETR for POP3) causes the s_client tool to renegotiate with the server.

The man page for s_client has some info in the "CONNECTED COMMANDS" section.

I managed to get my SMTP test working by using lowercase commands (rcpt to). I've just tried a test with GMail's POP3 server and using retr 1 works well.

share|improve this answer
    
Thanks that helped me a lot Kevin. the retr worked (lower case was correct!) –  user67025 Jan 16 '11 at 4:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.