Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The search service application in our farm went bonkers complaining that it couldn't connect to itself. After multiple people fiddling to try and fix it we've ended up with two search application. The new one, which is working perfectly, and the original one which is very unhappy.

I've tried deleting the original Search App in Central Admin but it just won't go - it sits on the screen saying "Processing" but it never completes regardless of how long it is left. There's lot's happening in the logs but I can't really decipher exactly why this isn't working.

Things are working fine within the farm but I'd ideally like to clean up this old application if possible. Are there any other options like deleting it with stsadm? I've had a dig but can't seem to find the commands to enumerate the service applications and then delete the correct one.

share|improve this question
up vote 2 down vote accepted

Found it!

Thanks to this blog I was able to delete the application - rather than dive in to the DBs as that article said I simply picked up the GUID that was displayed in the IE status bar whilst trying to delete the application in Central Admin.

share|improve this answer
don't know how safe it is, but using the GUID from the URL is a great tip. – MattB May 20 '10 at 19:23
Yeh - I should have put a health warning on it! Happily it worked in this case and binned the correct application but I'd always advise people to have a handy backup before doing any hacking with SharePoint! – Chris W May 21 '10 at 8:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.