Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to frame a page being served by SharePoint 2010's xlsviewer.aspx but this page is setting the HTTP response header X-FRAME-OPTION to SAMEORIGIN, so IE8 refuses to render the page in a frame on another domain, which is what I need.

It appears that no other pages being served by this SharePoint instance set X-FRAME-OPTIONS, only _layouts/xlsviewer.aspx

Where can I change the HTTP headers or framing options for SharePoint or this specific page?

Relevant headers:

GET //_layouts/xlviewer.aspx?id=whatever.xlsx&DefaultItemOpen=1

is returning:

HTTP/1.1 200 OK
. . .
X-Frame-Options: SAMEORIGIN
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
MicrosoftSharePointTeamServices: 14.0.0.4730
share|improve this question

2 Answers 2

Got to your Sharepoint Admin -> Manager Service Applications - > Excel Service Application ->Global Settings-> Check Allow Cross Domain Access

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.