Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a W2K3 Server that is the Domain Controller and also the DNS server. I wanted to make another DNS zone on my network called "something.local" and then make 'A' records to point requests like 'admin.something.local' and 'www.something.local' to machines on my network.

I keep getting DNS timeouts but then after 2 tries it succeeds. Why would this happen? How can I troubleshoot?

From my desktop I run:

nslookup admin.something.local

and get:

Server:  server.domain.com.au.local
Address:  192.168.0.10

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.

Name:    admin.something.local
Address:  192.168.0.191

If I go back the other way:

nslookup 192.168.0.191

I get:

Server:  server.domain.com.au.local
Address:  192.168.0.10

Name: admin.something.local
Address: 192.168.0.191
  • My DNS server address is 192.168.0.10.
  • The new DNS zone is not hooked up to active directory.
  • I do not have much experience with DNS.
  • Yesterday it was working fine.
  • I have tried doing an 'ipconfig /flushdns' on both my desktop and the DNS server
share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Good chance your DNS or client has a slight bit of physical resource contraints. This is more common when using virtualization with the DNS server and/or DNS client. Likely, the response to the query is returned just after the default 2 second wait time before timing out in nslookup.

Try this at a command prompt:

nslookup
timeout=3
admin.something.local

If that works the first time, that's likely the issue. The reason it worked the second time is the query is now cached in the DNS server's memory, thereby allowing it to respond without reading from disk the zone file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.