Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've recently been having some issues with SQL Server 2008 on our server. We only have one website running at the moment, but it seems at random that the following error occurs.

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.)

I don't understand this error, or what's causing it. Any help would be appreciated. When this error does occur all it takes to fix it is to restart the MSSQLSERVER service. But I need to fix the underlying problem first.

share|improve this question
    
is your SQL server and your IIS server running on the same machine? –  BlackICE May 21 '10 at 17:51
    
Yes the server hosts both IIS and SQL –  Matt May 21 '10 at 20:51
add comment

1 Answer 1

There are a number of things I found that can cause this, but the only one that makes sense with the issue being random as you describe is to check the maximum concurrent connections setting on the server. If that is set to something non-zero, either set it to zero or something higher than what it currently is.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.