Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I set all docroots to FollowSymLinks? I have a bunch of virtual host entries and don't want to modify each one.

Edit: I added 'Options +FollowSymLinks' in .htaccess and httpd.conf but I still receive 403 (Forbidden) errors :(. I even tried following SymLinks on twitter, but that didn't work either. http://twitter.com/SymLinks

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

If your virtual hosts are all under the same directory then just put it in a <Directory> section outside of all <virtualHost> sections.

share|improve this answer
1  
... but bear in mind if someone does Options None or Options -FollowSymlinks deeper in the configuration (or in .htaccess if they're allowed to) it will override your global setting. (At least if I'm remembering my Apache conf file semantics correctly) –  voretaq7 May 21 '10 at 16:19
    
Also All virtualhost definitions should contain "AllowOverride All". httpd.apache.org/docs/2.0/mod/core.html#allowoverride –  risyasin May 23 '10 at 16:54
add comment

Try this in the main configuration, you may can do it only for /www or something like that

<Directory />
Options +FollowSymLinks
</Directory> 
share|improve this answer
    
Thx! What does the '+' signify? –  John Himmelman May 21 '10 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.