Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Periodically my ASP.NET application crashes (usually because memory consumption exceeds maximum allowed by application pool) and DW20.exe starts up. This is a big problem because it uses huge amounts of memory and CPU for minutes at a time.

I want to know how to stop DW20.exe from running. Please note, I have already tried these often mentioned solutions:

  • Disabling error reporting in Control Panel > System > Advanced > Error Reporting

  • Disabling the Error Reporting Service

  • Modifying the registry as in (however I might have done this wrong - this doc says "add a DWReportee value of 1" - what I did was add a DWORD entry with hexadecimal value of 1 - is this right? Also only 2 of the 4 keys were present, so I only modified these, e.g. there was no HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\PCHealth key at all)

So, zero points for suggesting any of the above (unless you can see I have modified the registry incorrectly)! Also zero points for suggesting I resolve whatever is causing the application crashes :) - I am figuring this out, I just want something in the mean time to stop DW20.exe eating up all the server resources.

By the way, this is a Windows 2003 SP1 server, with IIS 6 and SQL 2005 installed. There is no MS Office.

share|improve this question
did you name the dword value DWReportee? – BlackICE May 21 '10 at 17:37
Would it be acceptable to blacklist the DW20.exe using a Local Group Policy Software Restriction? Or would that be "too hacky"? – jscott Sep 27 '11 at 12:29
You could fix your application to not exceed the memory pool. It's not DW20.exe that's causing your issues. I would spend more time on fixing the memory issues in your application. Doctor Watson is trying to tell you something is wrong. – Joseph Kern May 9 '12 at 2:31

There are four keys that need to be added. If the key or path does not exist, you need to add the key so that you all the way down to the value. DWord and hexadecimal 1 is fine.

You can create the path similar to the way you create folders in explorer.

Under Policies\Microsoft Right click in the window and select New->Key. Type PCHealth.

Under PCHealth Right click in the window and select New->Key. Type DW

Under DW Right Click and select DWORD Value. Name the value DWReportee and then set the value to 1 (whether it is decimal, hexadecimal,... is irrelevant since a 1 is a 1 in any number format)

All four values should be there. Rebooting will ensure a clear setting and all processes are reset.

share|improve this answer

I think what you want may actually be here: it was linked to from the kb article you mentioned.

Sorry, that looks specific to office, maybe worth a try tho.

This might be more helpful:

This is kinda a prelude to the prior mentioned article:

Looks to me like your best bet currently would be to try clearing the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\AeDebug\Debugger String, make sure to back it up first.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.