Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On our Mac OS X Server 10.5.x boxes, using spotlight (ie. the magnifying glass in the top corner) does not find applications and utilities, but it does on Mac OS X client (and so, we all use the keyboard shortcut and end up frustrated -- it either gives us nothing, or, without us realizing it until later, an application from another partition.)

It isn't clear to me if we've done something strange setting up our servers, but they are all like this. Any idea what caused it and how we fix it? Everything (including Applications) are set to show up in a spotlight search in System Preferences).

share|improve this question
up vote 2 down vote accepted

Have you tried rebuilding Spotlight's index? (basically forcing it):

sudo mdutil -i on /

Just in case you might want to play with turning it off first: off, or checking the status of the volumes: -s (man mdutil)

share|improve this answer
Left that one out in my answer - obviously if indexing is off (and it sometimes is for performance) you need to turn it back on :) – voretaq7 May 21 '10 at 16:29
That fixed it. As per another comment, I ran the check and saw that no hard drives are being indexed. (I don't know what is, as something comes up when I search!) I just don't understand why indexing would be turned off on all the drives. Perhaps there was an option at setup time to turn spotlight off that was used. – Clinton Blackmore May 21 '10 at 17:55
If you inherited the box it's possible someone turned off indexing for performance reasons (especially on something like a mail server with lots of little files). Not sure of OS X can turn it off on its own, but it may be possible... – voretaq7 May 21 '10 at 18:17

Stuff to Check (all needs to be run as root / with sudo):

  • Make sure Spotlight indexing is on (mdutil -s <volume> in the terminal)
  • Make Spotlight reindex the drive (mdutil -e <volume>)
    Note this just erases the data which will make spotlight start a reindex "when it feels like"
  • Force spotlight to import your applications folder (mdimport -f /Applications)
    (I think -f is deprecated in 10.5 and later, but you can use -d 1 to make it spit out debug data & be sure it's actually DOING something)

Not sure any of that will help - If not maybe the man pages for mdutil(1) / mdimport(1) / mdfind(1) / mds(8) will be more helpful than I was...

share|improve this answer
Very curious. I ran sudo mdutil -s /Volumes/* and indexing is turned off for all volumes. There are no privacy restrictions in system preferences telling it to omit a drive, and, again, everything is checked in the search results column. I have turned it on -- sudo mdutil -i on / as per a different comment, and checked the indexing status again -- it is now on, and, I hope, indexing. – Clinton Blackmore May 21 '10 at 17:43
+1 mdimport could be pretty useful tool for troubleshooting this too – l0c0b0x May 21 '10 at 18:10

Check system preferences -> Spotlight for checked "Applications" ? Spotlight Preferences Screenshot

share|improve this answer
Yes, it is checked. – Clinton Blackmore May 21 '10 at 17:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.