Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I,ve just installed a fresh copy of Ubunutu 10.04, downloaded a couple of days ago. The installation seemed to go fine. However I can't log in: the login screen just seems to reset and asks me for my password again.

It's not an authentication / incorrect password issue. If I stick in a wrong password, I get "Authentication failure".

I've googled around, others report the same issue on the Ubuntu forums, but there doesn't seem to be a fix. Does anyone know of a work around or what the problem is?

Have 9.10, I might end up just installing that instead.

THanks

share|improve this question

5 Answers 5

up vote 2 down vote accepted

what session are you using?

try to use GNOME or GNOME failsafe from the drop down menu at the bottom of the login screen

it happens with me when I try to use sugar for my children

also, I read some complaints about compiz compatibility with 10.04

share|improve this answer
    
Was using gnome anyway - however gnome failsafe has seemed to fix it. any idea what the difference is between them? –  Richard May 22 '10 at 10:57
    
yeah i have a crappy video card, could be that it can't handle the default effects –  Richard May 22 '10 at 11:06
    
it could be the compiz problem then. try to reduce the effects and re-log-in with GNOME once more. and try to check your Video driver, it might be not supported by the default distro, you might need to look for it and try once again –  A.Rashad May 22 '10 at 11:10
    
I am not sure what exactly is failsafe, but it seems to be something similar to safemode in windows. i.e. GNOME with minimal features to allow the session to start –  A.Rashad May 22 '10 at 11:11
    
Children and sugar is never a good combination –  pauska Jul 1 '11 at 6:55

To fix this issue you should reboot Your pc and start choose from the grid recovery ( second line ). chose from the list command promt using root type ---> passwd username enter the new password

type reboot now

and enjoy :)

NaderB

share|improve this answer
    
Also this should fix the issue for everyone :) –  Nader Barakat Jun 29 '10 at 16:05
    
It's not a problem with incorrect passwords, it's a problem with the session failing on login. That's caused by any number of things, including video problems if it's X or a problematic .bashrc file if it's command line. –  kaerast Jul 5 '10 at 11:15

I had this problem and it turned out to be a bug in the xserver-xorg-video-openchrome driver not handling AIGLX correctly. See [Bug 589520] at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/+bug/589520. You will be using this driver if you have VIA video hardware.

There is a workaround which involves inserting

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

in /etc/X11/xorg.conf

Create xorg.conf with just that entry if it doesn't exist (as it probably wont in a new installation of 10.04).

I hope this helps.

Cheers,

Stuart

share|improve this answer

After reading a few opinios and solutions, I've wondered if the problem seems to be with the openchrome... why not remove it ? ;) So here's what I did...

Logged in with failsafe graphical mode. Opened a terminal. Became root. Then typed (code):

aptitude purge xserver-xorg-video-openchrome

(accept the solutions)

Closed terminal. Restart.

At login screen Gnome session works perfectly.

Good luck. :)

share|improve this answer

It can also happen the us default keyboard driver must be changed to match your keyboard. you can do that with the menu, at bottom of the login screen

share|improve this answer
    
If you're talking about the keyboard layout / language selections, it would be pretty obvious if these were mismatched when typing your username... –  voretaq7 Nov 12 '12 at 0:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.