Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm banging my head against the wall here and can't get things figured out. Yesterday I uninstalled SQL Server 2008 Express and installed a full copy of SQL Server 2008 R2. Everything installed fine but I can't connect to the database to save my life. There is a similar question here that never got answered and I'm not sure if this may be specific to 2008 R2 and how I may have installed.

Under my old configuration (SQL Express) I connected with "DM\SQLEXPRESS" just fine. So far I've tried:

DM\MSSQLSERVER - .\MSSQLSERVER - \MSSQLSERVER - MSSQLSERVER - DM\Dave\MSSQLSERVER

and I get the "cannot connect to server" error every time.

I have the service installed as well as the SQL Server Browser that I have started. If anyone had any suggestions that would be great.

alt text

share|improve this question
    
@D.M.: what does the network configuration for your instance look like in SQL Config Manager? –  MattB May 24 '10 at 15:02

2 Answers 2

up vote 1 down vote accepted

If you've done a standard install using the default name (i.e. not a specified instance name) you should be able to connect to either "localhost" or "DM".

Does SQL Browser not return the name of the local service when you browse for SQL Servers?

share|improve this answer
    
Perfect, and duh. Just so I know going forward... Because I installed using the default instance I need to use "localhost"? If I would have selected a named instance I would have had to use the other server names? –  D.M. May 24 '10 at 16:15
    
localhost or the host name will work fine. There's a stage in the install wizard where you can either take the default name (i.e. host name only) or specify an instance name like you'd see with a default installation of the Express edition. So if you'd put in an instance name of MSSQLSERVER then your first two suggestions above should have worked. –  Chris W May 24 '10 at 17:03

you shouldnt need to specify the instance name for the default instance

have you tried using a . full stop or (local) for the name?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.