Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I run sar -d I receive the error message:

Requested activities not available in file /var/log/sysstat/sa24

The file does exist, and I can run sar with other flags, but can't see these particular metrics. Is there something I need to enable in sysstat to collect what I need to see this report?

Server is Ubuntu 9.04.

share|improve this question

4 Answers 4

Have you enabled it in: /etc/default/sysstat and made sure that SA1_OPTIONS="-S DISK" is not commented out?

Since you said you can get other information, I assume it is started it with /etc/init.d/sysstat start?

share|improve this answer
    
I did start sysstat with /etc/init.d/sysstat start, and /etc/default/sysstat contains the lines: ENABLED="true" SA1_OPTIONS="-S DISK" SA2_OPTIONS="" Maybe there ore other options I should have in SA1_OPTIONS or SA2_OPTIONS? –  Ryan Olson May 24 '10 at 19:18
    
That all works with my workstation (non-server). Maybe try stopping sysstat, moving the sa24 file somewhere else, and restarting sysstat? Perhaps your io device is a little bit non-standard and is not in sysstat.ioconf ? –  Kyle Brandt May 24 '10 at 19:22
    
I just tried this on a testing Ubuntu Server VM I have to make sure that there weren't any issues with apparmour but there weren't any. All I had to do was make the appropriate changes in /etc/default/sysstat and run sudo /etc/init.d/sysstat start –  3dinfluence May 24 '10 at 19:48

Can't speak for ubuntu but for red hat you have to change how it collects data in /usr/crond./sysstat:

from: /usr/lib/sa/sa1 1 1

to: /usr/lib/sa/sa1 -d 1 1

The -d says to collect disk stats. sa1 just calls /usr/lib/sa/sadc, if you want to see the doc for it do a man sadc.

This change doesn't take affect until the next time sa2 runs (I think). I always set it and then it starts collecting and working the next day.

share|improve this answer

I think sar -d is activated as default on Red Hat Enterprise Linux 6+ but not on 5 (I don't know about other distributions).

On RHEL 6 I edited a line in /etc/cron.d/sysstat to contain the "-d" option:

*/10 * * * * root /usr/lib64/sa/sa1 -d 1 1

Note: the "-S DISK" option, which is the default in RHEL 6+ (sysstat-9.0.4-18) did not work for RHEL 5 (sysstat-7.0.2-11).

The additional data is collected as soon as a new sa file is created the next day. If you are in a hurry, you could probably just delete today's sa file under /var/log/sa - but I did not try that out myself.

share|improve this answer

there is no file :sysstat in the /etc/init/d directory, the ekernel version is 2.6.18-164.el5 and the sar -d is not working:"Requested activities not available in file /var/log/sa/sa11"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.