Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have XAMPP installed. I am running Windows 7. I have WordPress installed so that I may tweak it and test things locally before putting them 'live' on a remote server. I just installed BuddyPress. The installation was rather seamless. I activated the plugin and almost immediately, Apache crashed. I have Apache running as a service so it immediately restarted itself and was running BUT if I even so much as refresh the page (or create any other request), down it goes.

Listed here is the error report as generated by Windows 7:

Problem signature:
  Problem Event Name: APPCRASH
  Application Name: apache.exe
  Application Version: 2.2.4.0
  Application Timestamp: 45ebef86
  Fault Module Name: ZendOptimizer.dll
  Fault Module Version: 0.0.0.0
  Fault Module Timestamp: 45ea8fee
  Exception Code: c0000005
  Exception Offset: 0004dc22
  OS Version: 6.1.7600.2.0.0.256.1
  Locale ID: 1033
  Additional Information 1: 1ec0
  Additional Information 2: 1ec0fd70d07d060e5bfcf53c69ad1739
  Additional Information 3: 2c48
  Additional Information 4: 2c48940de5e7d1cb2e131ad6a0ca2feb

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Help?

share|improve this question

3 Answers 3

I don't have a XAMPP installation handy, but try to remove (or comment out) the line referring to the ZendOptimizer.dll (which is the part that crashed) in your php.ini file and then restart it.

share|improve this answer
    
Would there be any harm in simply removing the entire [Zend] section from php.ini? –  Dan May 24 '10 at 22:32
    
If your problem isn't solved without just removing the Optimizer, just give it a try, if only to locate the problem. –  Sven May 25 '10 at 7:10

Solutions : - Try run XAMPP Control Panel as Administrator (Right Click menu on the shortcut). - Re-install XAMPP as Administrator (Right Click at .EXE file, choose "Run as administrator).

share|improve this answer

it looks like an OS problem, it may caused by UAC of windows 7. Zendoptimizer comes with Xampp is ok. tested may times over&over. Xampp always advices to turn off UAC. try without UAC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.