Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I currently have two Cisco ASA 5100 routers. They are at different physical sites and are configured with a site-to-site VPN which is active and working.

I can communicate with the subnets on either site from the other and both are connected to the internet, however I need to ensure that all the traffic at my remote site goes through this VPN to my site here. I know that the web traffic is doing so as a "tracert" confirms this, but I need to ensure that all other network traffic is being directed over this VPN to my network here.


Here is my config for the ASA router at my remote site:

hostname ciscoasa
domain-name xxxxx
enable password ######## encrypted
names
!
interface Ethernet0/0
 nameif NIACEDC
 security-level 100
 ip address x.x.x.x 255.255.255.0 
!
interface Ethernet0/1
 description External Janet Connection
 nameif JANET
 security-level 0
 ip address x.x.x.x 255.255.255.248 
!
interface Ethernet0/2
 shutdown
 no nameif
 security-level 100
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 security-level 100
 ip address dhcp setroute 
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.100.1 255.255.255.0 
 management-only
!
passwd ########## encrypted
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns domain-lookup NIACEDC
dns server-group DefaultDNS
 name-server 154.32.105.18
 name-server 154.32.107.18
 domain-name XXXX
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list ren_access_in extended permit ip any any 
access-list ren_access_in extended permit tcp any any 
access-list ren_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list NIACEDC_nat0_outbound extended permit ip 192.168.12.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list JANET_20_cryptomap extended permit ip 192.168.12.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list NIACEDC_access_in extended permit ip any any 
access-list NIACEDC_access_in extended permit tcp any any 
access-list JANET_access_out extended permit ip any any 
access-list NIACEDC_access_out extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu NIACEDC 1500
mtu JANET 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (NIACEDC) 1 interface
global (JANET) 1 interface
nat (NIACEDC) 0 access-list NIACEDC_nat0_outbound
nat (NIACEDC) 1 192.168.12.0 255.255.255.0
access-group NIACEDC_access_in in interface NIACEDC
access-group NIACEDC_access_out out interface NIACEDC
access-group JANET_access_out out interface JANET
route JANET 0.0.0.0 0.0.0.0 X.X.X.X 1
route JANET 0.0.0.0 0.0.0.0 192.168.3.248 tunneled
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.12.0 255.255.255.0 NIACEDC
http 192.168.100.0 255.255.255.0 management
http 192.168.9.0 255.255.255.0 NIACEDC
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto map JANET_map 20 match address JANET_20_cryptomap
crypto map JANET_map 20 set pfs 
crypto map JANET_map 20 set peer X.X.X.X 
crypto map JANET_map 20 set transform-set ESP-AES-256-SHA
crypto map JANET_map interface JANET
crypto isakmp enable JANET
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
tunnel-group X.X.X.X type ipsec-l2l
tunnel-group X.X.X.X ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.100.2-192.168.100.254 management
dhcpd enable management
!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect http 
!
service-policy global_policy global
prompt hostname context 
no asdm history enable

Thanks in advance,

Scott

share|improve this question
    
I've hidden a IP from your route-line, you probably didnt want that out in the open. –  pauska May 26 '10 at 9:41
    
I've also changed your "encrypted" passwords to "#####". However, you are now in danger of someone having full and unfettered access to your network. Cisco IOS passwords are a trivial thing to crack. I WOULD CHANGE YOUR ASA/VPN PASSWORDS IMMEDIATELY...and do not post those lines from your config again. –  GregD Sep 21 '10 at 13:22
    
Oh man. I see this post is from May. Ugh. I sure hope you've changed your passwords since then. –  GregD Sep 21 '10 at 13:26

1 Answer 1

From what I can see you're routing 0.0.0.0 0.0.0.0 (everything) to a IP across your VPN. Everything looks correct.

share|improve this answer
    
Thanks for looking at it and yes I believe you're right, however I still have one more issue and that is, although the web traffic is being sent over the VPN to the router here as required, it is not being filtered by our Check Point firewall like everything else on the subnet here! I've changed my client gateway to the router here and the web traffic isn't filtered either, does this mean that I need to put in a tunnel-rule in the routing on either/or routers?? Please help! –  Scott Clements May 26 '10 at 11:36
    
Is the default route pointing at your CheckPoint firewall? Should it be? –  dunxd Sep 22 '10 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.