Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have vsftpd installed on ubuntu. I added a new created a new user and set the users home path to /var/www so I can ftp with that user directly to that location. And that all works, I can now FTP with the user I created directly to that location. However I whenever I ftp, I have no permissions to change anything. How can I change that?

Thanks!!

UPDATE

OK, I set my user as the owner and confirmed the ownership. I even chmod the directory and its contents to 777 and verified that. I can make any change I want locally however I cannot make any changes via ftp. when using filezilla i get Critical file transfer error I also get an error when trying to modify a file with dreamweaver via ftp.

I am new to linux so I don't have any idea what is going on.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I've used vsftpd on Ubuntu in the past, and by default it is locked down to prevent any kind of write access regardless of the permissions. To fix this you need to make sure the following line in /etc/vsftpd.conf is uncommented and then restart vsftpd:

First, from a terminal window, edit the config file for vsftpd:

sudo nano /etc/vsftpd.conf

Or you can use gedit to alter the file if you prefer:

gksudo gedit /etc/vsftpd.conf

Then find the following section:

# Uncomment this to enable any form of FTP write command.
#write_enable=YES

and change it to this (remove the # in front of the second line) and make sure it is set to YES:

# Uncomment this to enable any form of FTP write command.
write_enable=YES

And then restart your vsftpd process (or just reboot your computer):

 sudo /etc/init.d/vsftpd restart

And then you should have write access as long as your user has the correct permissions.

share|improve this answer
    
Thank you so much, I was really getting frustrated with this one! :) –  JD Isaacks May 26 '10 at 13:56
    
It had me banging my head off the desk for a while too ;-) –  John Rabotnik May 26 '10 at 14:02

you need to switch ownership for /var/www to that user

Easy way is

chown -R user: /var/www

The -R handles everything below also

share|improve this answer
    
am I supposed to replace user with the username I want to change? Thanks –  JD Isaacks May 26 '10 at 13:22
    
yes.. change user to the user you want to give rights to –  Mike May 26 '10 at 13:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.