Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install some software in a fresh install of Linux dnoseda 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux. I already set the variables http_proxy, https_proxy and ftp_proxy and wget works perfectly.

But when I try with apt-get it blocks trying to conect directly to the site, without the proxy. Or the other behavior that I got is a lots of 407 authentication errors. But the wget of those packages works perfectly.

It's something missing? Can you help me?

thanks in advance.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You need to set the apt-parameters:

Acquire::http { Proxy "http://proxy:port"; };

inside a /etc/apt/apt.conf.d/90proxy file or similar.

edit: you need to do an apt-get update after changing the settings.

share|improve this answer
    
The file doesn't exists.Do I have to create 90proxy? –  damian May 26 '10 at 15:13
    
it works! but now dpkg doesn't work. It still trying to make a direct internet connection :( –  damian May 26 '10 at 15:34
    
dpkg shouldn't be connecting to the network. it should be using the packages that are downloaded. did you do an apt-get update after changing the settings. –  sybreon May 27 '10 at 1:26

Do you have those exported as root? or do you have them set as the user and using sudo apt-get?

If you are using sudo.. place the lines in

/etc/profile 
share|improve this answer
    
Thanks. I'm using sudo. I'm going to try to export the proxies variables in /etc/profile. Then I'm going to update the status. –  damian May 26 '10 at 14:10
    
It doesn't work, even after reboot. It seems to try to do a direct connection with the urls –  damian May 26 '10 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.