Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed Ubuntu 10.04 (64bit) as a guest OS in VirtualBox, using Windows 7 Professional (64bit) as host.

After Ubuntu install, I did installed Xfce4 (sudo apt-get install xfce4). Logged in using a Xfce session, and when I logged out, I couldn't see the login box anymore, only the regular Gnome background from login screen.

Then I restarted the virtual machine, and now I'm not able to see the login box anymore, only the gnome background.

Does someone knows how to solve this?

Update: I've tried to use Xubuntu, that comes with Xfce. And I'm facing the same problem. As a common denominator from the two cases, now I see the problem arises after I've updated the system, and then installed curl (via apt-get), zlib (make process), git (make process). But I'm not sure this can be the cause for this ...

Update: I isolated the problem. The bad guy is zlib, but I don't have a clue why. In fact, it does crash not only ubuntu and xubuntu, but also Debian (Yes, I've tested all). I'll keep this question in case someone have the same problem, but I think my initial question is not valid anymore.

share|improve this question
add comment

4 Answers

Try reinstalling GDM:

sudo apt-get install --reinstall gdm

You will naturally need terminal access for that - use Ctrl+alt+F1 to get to the virtual console.

share|improve this answer
    
Thanks for the answer Vitaliy, but it didn't work. I still can't see the login box. –  Alexandre May 26 '10 at 16:32
add comment

i'm having the same problem - no login window shown for gdm, just blank desktop background...

and uninstalling zlib helped...

share|improve this answer
add comment

You didn't say what version of zlib.

You may have an older version of libxml that needs to be updated.

share|improve this answer
add comment

I also ran across this problem. I installed zlib on ubuntu 9.10 and then firefox immediately started crashing with a segmentation fault. Then I couldn't get a login box, just the orange ubunu background screen. Nothing worked until I removed libz from /usr/local/lib. It was version 1.2.5 of zlib. Thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.