Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

A few days ago I installed Win7 32bit on a PC and it wouldn't talk to my Lacie NAS which is running WinXP embedded. My other Win7 PC's had no problem.

After a bit of searching I found a forum post that told me to enable older networking protocols on the Win7 PC, I think it was win98 protocols or something like that. I had to run a .msc program to do this. It fixed the problem.

Now, I have a similar problem on another Win7 PC and for the life of me cannot find that posting and cannot remember what I did!

Does anyone know the program or setting to do this?

Thanks, Will.

share|improve this question

1 Answer 1

This is probably a Superuser question more than a Server Fault question, but I did want to make the point that a NAS running Windows XP embedded isn't, very likely, using any really old networking protocols (from a Microsoft networking perspective). Until you get back to the Windows 95/98 days (or prior), you're not going to run into really icky stuff like NetBEUI.

If the NAS is running Windows XP Embedded then it shouldn't have any problem with SMB password encryption. Not having used a lot of LaCie products I can't say for sure what the problem is you're seeing, but I sincerely doubt the LaCie is exporting any Windows file sharing protocol other than NetBIOS over TCP / SMB.

I suppose you could attempt to enable plaintext SMB authentication just to see if it fixes your problem, though. Its unclear to me whether this would work on Windows 7 or not, but you could try setting the DWORD value "EnablePlainTextPassword" to "1" at "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkStation\Parameters". Reboot (or stop and restart the "Workstation" service) and see what that does.

Check out Chris S comment below. It's very likely that the default LMCompatibilityLevel of Windows 7 (which is "3", meaning "Send NTLMv2 only") is causing your problem if your LaCie device is using an older SMB server (like a Samba version pre-3.0.21, for example).

share|improve this answer
1  
It may be running WinCE, which wouldn't support NTLMv2. By default Win7 will not use NTLMv1, which shows up as an authentication error. The first answer on this page has the registry settings if this is the case: social.technet.microsoft.com/Forums/en-US/w7itpronetworking/… –  Chris S May 27 '10 at 0:30
    
@Chris S: Seems like a great idea. I didn't even realize that my home Samba server supported NTLMv2, but that's likely the reason I didn't run afoul of this one myself... –  Evan Anderson May 27 '10 at 2:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.