Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'll try to be as specific as I can be:

  • Server is running SBS 2008 R2 (with all updates)
  • Server is connected to the internet
  • Server has 2 NIC's, one is disabled
  • Server is running RDP Service (accessible directly from the internet, I know, not as secure as it should be)
  • Computers A and B are on the same local net.
  • Computers A and B are both Windows 7.
  • Users X and Y are both admins on the server
  • Computer A can connect as user X to the server with mstsc
  • Computer A can connect as user Y to the server with mstsc
  • Computer B can connect as user X to the server with mstsc
  • Computer B CANNOT connect as user Y to the server with mstsc! Error that username/password is incorrect.

The last point is the problem, I get an authentication error. This used to work flawlessly for the last year. The server and desktops have been rebooted.

EDIT:

I tried:

  • prefixing domain to the username
  • prefixing the server computer name to the username
  • change the password
  • copy/paste the password from notepad to make sure it was correct

I find it very strange....

EDIT:

  • The computers are not on the same subnet as the server. The server is at my hosting provider.
  • All computers as all users can reach the web app that is running on the server.
share|improve this question
    
We had exactly same issue with service accounts we had just created in Windows 2008 R2 Enterprise Active Directory. All attempts to store password in KeePass or notepad and log in later failed. Only typing the password in from keyboard worked. Very frustrating. Our RDP client was on Windows 7 machine. I was thinking it might be some kind of unicode mismatch, and my partner is thinking maybe one of the RDP clients is out of date. Really scratching my head over this one. –  user75802 Mar 25 '11 at 3:27
    
Is AD involved? –  Falcon Momot Aug 13 '12 at 6:04
    
I've had a strange experience similar to user75802 where I discovered that KeePass requires me to use ctrl-v to paste a password into the RemoteDesktop authentication box. In this case, what does the Security event log show for the successful and failed logins? It should include fail reasons for failures. –  Slartibartfast Mar 6 at 5:32

3 Answers 3

You must fully qualify the user accounts you are passing like DOMAIN\username or username@domainname

Outside of that we need more info about the exact error message. A screenshot would be good.

share|improve this answer
    
See my edit. The error message is in Dutch but it is exactly as if you have a invalid user/pass. No other info like an error code is given. Just "authentication failed". pw is correct, from another machine it does work..... –  John Landheer May 27 '10 at 13:18

I was having this exact same issue. All I did was log into the local administrator account via RDP, logged out, and all users were fixed.

The local administrator account did NOT have an active session after a server reboot. Very strange.

share|improve this answer

Check if you have already set up userpassword on account Y settings of computer b

Control Panel -> Credentials Manager.

Also Usefull cane be to clear the server that you have problems from your clients registry

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.