Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed Windows instructions, and turned on several parts of IIS. But http://localhost isn't working, and I don't see the IIS entry in Administrative Tools either.

I only want to use SSI, not ASP(.net) or FTP. What should I check and why isn't it working? It didn't ask me to restart Windows, is that required?

OK I have management console now but no joy. "Default Web Site" is shown as stopped, when I try to start it I get:

Internet Information Services (IIS) Manager

The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Basically it is some other application that is bound to 80 and is not allowing website on IIS to use it.

The following command should help you to find out the application/pid using port 80.

netstat -ab | find ":80 "

change 80 with custom port in case you are running website off a custom port.

In my case it was skype that was using it. Very strange. Closed skype and then started website, website ran fine. Then started skype too. Skype running fine too.

share|improve this answer
    
Skype is known to have issues with IIS, so this could be a possibility. –  Cold T Apr 4 '12 at 7:54

You need to check "IIS Management Console" under Internet Information Services -> Web Management Tools.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.