Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've setup subversion on Ubuntu 10.04, but can't get authentication to work. I believe all my config files are setup correctly, However I keep getting prompted for credentials on a SVN CHECKOUT. Like there is an issue with apache2 talking to svnserve. If I allow anonymous access checkout works fine.

Does anybody know if there is a known issue with subversion and 10.04 or see a error in my configuration?

below is my configuration:


# fresh install of Ubuntu 10.04 LTS 32bit

sudo apt-get install apache2 apache2-utils -y
sudo apt-get install subversion libapache2-svn subversion-tools -y
sudo mkdir /svn
sudo svnadmin create /svn/DataTeam
sudo svnadmin create /svn/ReportingTeam

#Setup the svn config file
sudo vi /etc/apache2/mods-available/dav_svn.conf
#replace file with the following.
<Location /svn>
  DAV svn
  SVNParentPath /svn/
  AuthType Basic
  AuthName "Subversion Server"
  AuthUserFile /etc/apache2/dav_svn.passwd
  Require valid-user
  AuthzSVNAccessFile /etc/apache2/svn_acl
</Location>

sudo touch /etc/apache2/svn_acl
#replace file with the following.
[groups]
 dba_group = tom, jerry
 report_group = tom

[DataTeam:/]
 @dba_group  = rw

[ReportingTeam:/]
 @report_group  = rw

#Start/Stop subversion automatically
sudo /etc/init.d/apache2 restart
cd /etc/init.d/
sudo touch subversion
sudo cat 'svnserve -d -r /svn' > svnserve
sudo cat '/etc/init.d/apache2 restart' >> svnserve
sudo chmod +x svnserve
sudo update-rc.d svnserve defaults

#Add svn users
sudo htpasswd -cpb /etc/apache2/dav_svn.passwd tom tom
sudo htpasswd -pb /etc/apache2/dav_svn.passwd jerry jerry

#Test by performing a checkout
sudo svnserve -d -r /svn
sudo /etc/init.d/apache2 restart
svn checkout http://127.0.0.1/svn/DataTeam /tmp/DataTeam
share|improve this question

2 Answers 2

Since it's DAV, you'll want to check apache error logs for auth failures. Can you auth correctly with your browser?

share|improve this answer
    
The apache logs say pretty much the same thing as the console -- That the password is incorrect. But the password are correct, that's why i modified to store them in plain text for this question. I'm at a loss on this one. Here's the apache log entry: "user jerry: authentication failure for "/svn/DataTeam": Password Mismatch" –  Chad May 27 '10 at 19:13

Why are you using both svnserve and apache? You can use either, but using both is asking for trouble.

To serve subversion over http you need mod_dav and mod_svn enabled in apache.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.