Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We're trying to move our internal ticketing system from a Microsoft Small Business Server in the server closet to a Rackspace Cloud Server. The install is Fedora 11 LAMP, and should be default out of the box, except for the vhosts appended to the bottom of the httpd.conf.

The new server is suffering from crippling load times, and watching the page load in Firebug it's easy to see the problem occurring, but I can't figure out the cause.

Here is the old server: old server

I was expecting something like this, but a little slower since it was no longer hosted locally. Instead, the new server: new server

appears to only serve one file at a time. Here's another example of this staircase load time effect: staircase load time effect

and another very clear example of the staircase effect: staircase effect 2

I talked to some guys on Freenode #httpd with no luck. I created a duplicate server to play with, and also created a fresh server with Fedora Core 13 and moved over just the database and web files with no luck.

Any suggestions?

share|improve this question
    
I found the exact same problem on ServerFault. Same hosting, Rackspace Cloud Server running Fedora 11 with Apache 2: serverfault.com/questions/123508/… Unfortunately, the issue was never resolved. Also, could someone with 10 rep change the tags now that I know more about the issue: apache fedora rackspace dns dns-hosting –  Robert Kuykendall May 28 '10 at 15:27
    
We spun up a Gentoo install and it's working correctly! You can see the changes in the Firebug screenshot below. rkuykendall.com/uploads/gentoo-fixed.png This doesn't exactly solve our problem since we'd like to stay on Fedora, but at least it gives us more insight and a way out if we can't fix Fedora. –  Robert Kuykendall May 28 '10 at 15:55

2 Answers 2

up vote 1 down vote accepted

We figured it out! It was an IPTables configuration problem.

We spun up yet another test server to try to find the problem, this time CentOS. The problem wasn't presenting, so we turned on IPTables to begin switching to the new server. Upon enabling IPTables, the problem returned. We investigated the config file and found -m limit --limit 1/s in the configuration.

Removing -m limit --limit 1/s from our iptables configuraton solved the problem presented.

share|improve this answer

Your load time is ridiculous because the browser can't find 9 files that it needs to download. Three of the CSS files take 30 seconds and one 20 seconds to timeout before it opens another connection. Fix all the items appearing in red on this(http://rkuykendall.com/uploads/staircase.png) screen shot and performance will be much better.

The Technical details are that HTTP/1.1 spec recommends that browsers only make two concurrent connections at the same time per domain. Since it's all coming from the same domain in this example, it takes as long as 30 seconds for the missing files to timeout hence only one other file can be download.

share|improve this answer
    
The two last screenshots are of the same page. The only missing file is the one at the very bottom and that returns a 404 very quickly. The red files you see on the second to last screenshots are timeouts or something. –  Robert Kuykendall May 28 '10 at 15:09
    
My answer to your issue related to this screenshot (rkuykendall.com/uploads/staircase.png) here is correct. –  citadelgrad May 29 '10 at 23:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.