Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having trouble installing mod_xsendfile on MAMP.

I've used some sources to try to help me install it:
http://iprog.com/posting/2008/04/compiling_mod_xsendfile_for_mac_os_x
http://groups.google.com/group/phusion-passenger/browse_thread/thread/e6dac9d5ea0de9c1

I ended up installing apache20 via macports and used apsx command to create the module and then copy it into MAMP's modules folder.

I was able to seem to load the module at least. But then I get this error in my apache logs:

[Thu May 27 19:08:28 2010] [notice] child pid 68606 exit signal Bus error (10)
[Thu May 27 19:08:41 2010] [notice] child pid 68607 exit signal Bus error (10)

Can anyone help me out? :S

share|improve this question

1 Answer 1

Try this :)

http://elivz.com/blog/single/mod_xsendfile/

share|improve this answer
1  
Generally it is better to extract the main content from that link, or else people have to follow these links to see if that is maybe what they want. Also, eventually the link might disappear. –  Kyle Brandt Dec 20 '10 at 15:58
    
Okay will keep your advice for future. :) –  SalmanPK Dec 22 '10 at 20:39
1  
If I were you I would edit my answer and include the information :) –  Lucas Kauffman Jul 23 '12 at 10:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.