Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hey guys, I'm not too savvy with ASDM and it has been quite some time since I have done anything IOS so forgive me.

I am trying to forward port 3389 from 'any' on 'outside' (1.1.1.1) to an internal server (10.10.10.10). Can anybody give me the steps to do this using ASDM or IOS.

Thanks,

-Jason

share|improve this question

2 Answers 2

You need to do two things to set up what you want. You need to set up the port forwarding and then also allow the traffic through the firewall.

In ASDM, go to Configuration -> Firewall.

To allow traffic through the firewall, go to Access Rules and click Add, then enter these values:

Interface: outside
Action: Permit
Source: any
Destination: 1.1.1.1 (your external IP address)
Server: tcp/3389

To add the port forwarding rule, go to NAT Rules (below Access Rules) and click Add, then Add Static NAT Rule..., then put these in:

Original
    Interface: inside
    Source: 10.10.10.10
Translated
    Interface: outside
    Use IP Address: 1.1.1.1
Port Address Translation (PAT)
    Enable Port Address Translation (PAT)
    Protocol: TCP
    Original Port: 3389
    Translated Port: 3389
share|improve this answer

Assuming you're using ASA before 8.3 (you did mention asdm 6.0, so I guess this isn't an assumption) and the outside address is the address of the interface. Here would be the CLI commands:

static (inside,outside) tcp interface 3389 10.10.10.10 3389 netmask 255.255.255.255
access-list outside_access_in extended permit tcp any host 1.1.1.1 eq 3389
access-group outside_access_in in interface outside

If that outside address is not the same as the interface address, change the static command to this:
static (inside,outside) tcp 1.1.1.1 3389 10.10.10.10 3389 netmask 255.255.255.255

I'm sure ASDM has similar fields if you look for them, but I'm not too savvy with ASDM myself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.