Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've set up a Windows 2003 server with IIS 6 and the FTP is Filezilla. I'm not a sys admin by any means and neither is my other developer. I'm trying to connect to FTP on a Mac with a Cyberduck FTP client. I'm running OSX 10.6.3.

The problem is that I can connect to the FTP address, but when I do it will hang for a minute or two trying to list the directories. This address is pointed to the webroot folder so it's only trying to list the pertinent folders for the site we're working on. Eventually after a minute or two it will go through and list everything and then if you try and open a file or another folder, it will hang again and then eventually list the folders.

My question: Is there some stupid default setting we're missing? Is this a common occurrence? Like I said I'm not a sys admin at all and I'm sure I'm missing some valuable questions for anyone that reads this, so please fire away if you can help and you need more info, I'll do my best to provide it.

Thanks!

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

If you are using FileZilla Server, then you don't need to worry about IIS, since Filezilla Server is handling the serving of the files.

I would check to make sure PASSIVE FTP is disabled on the Cyberduck FTP client. Also make sure that the Filezilla Server's user has read/write/modify (or whatever access they need to have) access to the directory in question.

You may wish to refer to this resource as well: http://wiki.filezilla-project.org/Network_Configuration

share|improve this answer
    
Yea, it was a Cyberduck setting, dumb dumb dumb haha. Thanks a lot! I wish I had the rep to upvote you. –  vanhornRF May 28 '10 at 16:22
    
My pleasure! Was it the passive ftp issue? –  Phanto May 28 '10 at 17:31
add comment

What happens if you try accessing the server locally from the windows box? Open a My Computer and in the address bar type: ftp://username@your.ip.address . Is it working as slow?

share|improve this answer
    
It works locally, Mikee was right, it was a Cyberduck setting, we're dumb, thanks! –  vanhornRF May 28 '10 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.