Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

System: HP Proliant DL360 G5 running CentOS 5.4

Bonded interface is working fine for a long time. I just went to add an alias the way I always have on a regular interface, and on first check it works (pinging on the local box) but it is not accessable from outside (iptables is turned off). In addition with this setup the normal network response started to decline, hanging for around a minute before I could get a prompt on login.

Here are my config files:

[root network-scripts]# cat ifcfg-eth0 
DEVICE=eth0
BOOTPROTO=none
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no

[root network-scripts]# cat ifcfg-eth1
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no

[root network-scripts]# cat ifcfg-bond0 
DEVICE=bond0
BONDING_OPTS="mode=1 miimon=100"
BOOTPROTO=none
ONBOOT=yes
NETWORK=10.2.1.0
NETMASK=255.255.255.0
IPADDR=10.2.1.11
USERCTL=no

[root network-scripts]# cat ifcfg-bond0:1 
DEVICE=bond0:1
BOOTPROTO=static
ONBOOT=yes
NETWORK=10.2.1.0
NETMASK=255.255.255.0
IPADDR=10.2.1.12
USERCTL=no

any thoughts?

share|improve this question
    
So did you solve it? –  edgars Oct 26 '10 at 13:54
add comment

4 Answers

Does the bonding kernel module loads properly or not ?

If not, it could be related to a dependency issue w/ ipv6, appeared in rhel5.4 with bonding driver 3.4.0.

the following commands should resolve this issue:

# touch /etc/modprobe.d/disable-ipv6
# echo "options ipv6 disable=1" >> /etc/modprobe.d/disable-ipv6 
share|improve this answer
add comment

bond0:1 is still driven by a bond driver. Create eth0:1 and eth1:1 and bond them.

share|improve this answer
1  
Rubbish. Adding aliases for eth0 and eth1 will not solve anything. It is perfectly ok to create an alias for bond0 without aliasing its slaves. –  wzzrd Jul 21 '11 at 10:13
add comment

You do not have a GATEWAY line. The only thing that can reach those interfaces are other devices on the same vlan

share|improve this answer
add comment

Please add NM_CONTROLLED=no in ifcfg-bond0 abd restart once. may help you.

share|improve this answer
    
Please read blog.serverfault.com/2011/06/09/press-the-green-button-twice and consider improving your answer. –  voretaq7 Nov 22 '13 at 7:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.