Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get Zend Framework working with netbeans, but every time there is the error

"php.exe"' is not recognized as an internal or external command, operable program or batch file.

I am using WAMP server 2.0 it is installed in e:\wamp

My Zend framework is inside e:\wamp\www\ZendFramework-1.10.5

I have located the ZendFramework script as: E:\wamp\www\ZendFramework-1.10.5\bin\zf.bat

I am also registered the module.

What am i doing wrong?

I am running on Windows 7 32 bit, using NETbean 6.9 RC1

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

easy just add the path of your php.exe to your path variable i guess it was rightclick on Mycomputer -> advanced tab -> environment variables -> then go to the PATH variable and append the path to the PHP.exe and don't forget to append the path to zf.bat after it and go ahead

share|improve this answer
add comment

Just adding my bit to this: after trying for hours with wamp and now with xampp the missing piece that it took me a while to find is to change the SET PHP_BIN variable in the zf.bat script from php.exe to the full path of your php installation - for xampp default this would be c:\xampp\php

so zf.bat should have the PHP_BIN set like

SET PHP_BIN=c:\xampp\php\php.exe

I'd set my Path to include the right path but still no joy. The answer above does suggest this change in zf.bat but I for one didn't get exactly what I had to change until I carefully examined the zf.bat script.

Hope that fixes someone else's frustration too.

share|improve this answer
    
i saw this post after 2 hours of my struggle!! thanks Alex!! –  Deepak Apr 3 '12 at 10:51
add comment

Never tried Netbeans with the zf tool, but you got 2 possible points of failure here:

  • Netbeans doesn't find your PHP binary (php.exe) - set it in Settings - PHP - PHP 5 Interpreter (it's somewhere in the WAMP directory, sorry I don't use WAMP)
  • The zf tool doesn't find your PHP binary - change the batch file to use the correct binary or add the path with the binary to your system's PATH variable
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.