Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have changed the apache2.conf so that my website requires authentication.

This works fine when typing the adress like this: www.domain.com or my_ip/

Problem is, I have Solr, which admin interface is on port 8983, so this:

 www.domain.com:8983/

does not require authorization.

How can I add this port to also be authorized?

Thanks

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I am not an expert with Solr, but it seems to me that this admin interface is not being served through your configured apache instance. From what I see, Solr has built-in tomcat for this purpose. Have you checked the Solr wiki / documentation? You will need to configure tomcat to require authentication for this url.

share|improve this answer

in fact there is no option for authentication on ports. you need to know where is the documentroot of solr in file system. & you can handle a basic authentication realm on that directory.

here is a complete guide to get it working, http://httpd.apache.org/docs/2.0/howto/auth.html just find the directory of Solr's documentroot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.