Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Alright, so I'm having this issue with SquirrelMail and Courier IMAP. When I try to login to SM, it throws this error at me:

ERROR: Connection dropped by IMAP server.

The IMAP server is running on 993 without SSL (which might be the problem). How do I fix this, and I've already taken a look at the official documentation in relation to this error with no fix.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

As Bill said, 993 is usually IMAPS. Are you sure it's running without SSL? What happens when you do:

telnet serverip 993

Do you get a greeting? If not, what about:

openssl s_client -connect serverip:993

If you get a response in either, just type:

A01 LOGOUT

It'll disconnect.

If you get a response from the first, what does it say? If you get a response on the second, it means you are running IMAPS, which means you need to change your config/config.php settings for your imap connection (see $use_imap_tls).

As a side, Courier defaults to limiting connections from a single IP to 4 connections. If multiple people will be using this SquirrelMail install, you'll want to increase that limit, see the MAXPERIP setting in the imapd config file.

share|improve this answer

Port 993 is IMAPS (with SSL) dovecot may be automatically trying SSL as per standards. Check that the use_imap_tls option is set to false. If at all possible enable SSL on port 993 or use port 143 IMAP.

share|improve this answer
    
It would appear that we have two pieces of software competiting (Dovecot and Courier), so how do I disable one and enable another? –  Nik May 30 '10 at 0:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.