Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Timeout error occurred trying to start MySQL Daemon.

The above error comes when i run the following command "service mysqld start"

this error comes on centos 5 after reboot the system

please help me i'm a new bie on centos 5 and i'm stuck here

share|improve this question

migrated from May 30 '10 at 18:17

This question came from our site for professional and enthusiast programmers.

Check if mysql process isn't already running.

Also check in my.cnf if you have correct bind-address parameter set. It could be either, or your external IP. If it's some other IP, it could cause the problem.

share|improve this answer

I know this thread is old. I'm just adding a post for anyone else that has this issue and finds this thread while looking for an answer.

We had the same error after rebooting a RHEL5 server. In our case, the mysql user's UID and primary group were changed, so the database did not have access to any files in /var/lib/mysql.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.