Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The problem:

  • If i access SharePoint from Windows 7 with IE8 or Chrome5 - I must wait for like a minute to get a response. If i use other Windows 7 with IE8, just the same - just wait a MINUTE.
  • If i use Firefox3.6 on W7 machine - page opens up instantly.
  • Now switch to IE rendering engine in Firefox, you will have to wait just as with IE.
  • Now i tried IE8 on XP SP3 - page opens up instantly.
  • I tried IE8 on Windows Server 2003 SP2 (machine on which SharePoint is hosted) - page opens up instantly.

IIS6 Logs

I did request almost instantly from all 3 browsers and this is what shows up in IIS logs (first 2 entries for each browser):

Chrome

Ok, IIS saw first Chrome request when i Hit enter in browser, but i had to wait long for things to move on

2010-06-01 05:46:04 W3SVC1794621940 192.168.0.9 GET /sapulces - 80 - 192.168.0.186 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+en-US)+AppleWebKit/533.4+(KHTML,+like+Gecko)+Chrome/5.0.375.55+Safari/533.4 401 2 2148074254

Loading...

2010-06-01 05:47:07 W3SVC1794621940 192.168.0.9 GET /sapulces - 80 - 192.168.0.186 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+en-US)+AppleWebKit/533.4+(KHTML,+like+Gecko)+Chrome/5.0.375.55+Safari/533.4 401 1 0

... etc...

Firefox

All Instantly

2010-06-01 05:46:06 W3SVC1794621940 192.168.0.9 GET /sapulces - 80 - 192.168.0.186 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+lv;+rv:1.9.2.3)+Gecko/20100401+Firefox/3.6.3 401 2 2148074254

2010-06-01 05:46:06 W3SVC1794621940 192.168.0.9 GET /sapulces - 80 - 192.168.0.186 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+lv;+rv:1.9.2.3)+Gecko/20100401+Firefox/3.6.3 401 1 0

... etc...

IE

I did hit enter when it was 05:46:06, but these are first entries in IIS logs

2010-06-01 05:47:08 W3SVC1794621940 192.168.0.9 GET /sapulces - 80 - 192.168.0.186 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+.NET+CLR+1.1.4322;+.NET4.0C;+.NET4.0E) 401 1 0

2010-06-01 05:47:08 W3SVC1794621940 192.168.0.9 GET /sapulces - 80 - 192.168.0.186 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+.NET+CLR+1.1.4322;+.NET4.0C;+.NET4.0E) 401 1 0

... etc...

Nothing to see in Event Logs.

Fiddler

IE

GET /dokumenti HTTP/1.1
Accept: image/jpeg, application/x-ms-application, image/gif, application/xaml+xml, image/pjpeg, application/x-ms-xbap, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, application/x-shockwave-flash, */*
Accept-Language: lv-LV
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E)
Accept-Encoding: gzip, deflate
Connection: Keep-Alive
Host: serveris

HTTP/1.1 401 Unauthorized
Content-Length: 1656
Content-Type: text/html
Server: Microsoft-IIS/6.0
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
MicrosoftSharePointTeamServices: 12.0.0.6520
X-Powered-By: ASP.NET
Date: Mon, 07 Jun 2010 08:40:46 GMT
Proxy-Support: Session-Based-Authentication

------------------------------------------------------------------
GET /dokumenti HTTP/1.1
Accept: image/jpeg, application/x-ms-application, image/gif, application/xaml+xml, image/pjpeg, application/x-ms-xbap, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, application/x-shockwave-flash, */*
Accept-Language: lv-LV
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E)
Accept-Encoding: gzip, deflate
Connection: Keep-Alive
Host: serveris
Authorization: Negotiate TlRMTVNTUAABAAAAl4II4gAAAAAAAAAAAAAAAAAAAAAGAbAdAAAADw==

HTTP/1.1 401 Unauthorized
Content-Length: 1539
Content-Type: text/html
Server: Microsoft-IIS/6.0
WWW-Authenticate: Negotiate TlRMTVNTUAACAAAAEgASADgAAAAVgonihccyI36f5i4AAAAAAAAAAIIAggBKAAAABQLODgAAAA9CAEEATABUAEkAQwBPAFYATwACABIAQgBBAEwAVABJAEMATwBWAE8AAQAQAFMARQBSAFYARQBSAEkAUwAEABIAQgBhAGwAdABpAGMAbwB2AG8AAwAkAHMAZQByAHYAZQByAGkAcwAuAEIAYQBsAHQAaQBjAG8AdgBvAAUAEgBCAGEAbAB0AGkAYwBvAHYAbwAAAAAA
MicrosoftSharePointTeamServices: 12.0.0.6520
X-Powered-By: ASP.NET
Date: Mon, 07 Jun 2010 08:41:49 GMT
Proxy-Support: Session-Based-Authentication

------------------------------------------------------------------
GET /dokumenti HTTP/1.1
Accept: image/jpeg, application/x-ms-application, image/gif, application/xaml+xml, image/pjpeg, application/x-ms-xbap, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, application/x-shockwave-flash, */*
Accept-Language: lv-LV
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E)
Accept-Encoding: gzip, deflate
Connection: Keep-Alive
Authorization: Negotiate TlRMTVNTUAADAAAAGAAYAJgAAAAYABgAsAAAABIAEgBYAAAAHgAeAGoAAAAQABAAiAAAABAAEADIAAAAFYKI4gYBsB0AAAAPirSYl+w3M1gPelXA+mS9OEIAQQBMAFQASQBDAE8AVgBPAGoAYQBuAGkAcwAuAHYAZQBpAG4AYgBlAHIAZwBzAEoAQQBOAEkAUwAtAFAAQwCxt4kZryxtOgAAAAAAAAAAAAAAAAAAAAC7gY8LTv2TqmFbggCo52sIVw8zy2V/s0ZHHFSqA0tiiGpcNplfJlok
Host: serveris

HTTP/1.1 302 Object Moved
Content-Length: 161
Content-Type: text/html
Location: http://serveris/dokumenti/default.aspx
Server: Microsoft-IIS/6.0
MicrosoftSharePointTeamServices: 12.0.0.6520
X-Powered-By: ASP.NET
Date: Mon, 07 Jun 2010 08:41:49 GMT

------------------------------------------------------------------
GET /dokumenti/default.aspx HTTP/1.1
Accept: image/jpeg, application/x-ms-application, image/gif, application/xaml+xml, image/pjpeg, application/x-ms-xbap, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, application/x-shockwave-flash, */*
Accept-Language: lv-LV
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E)
Accept-Encoding: gzip, deflate
Connection: Keep-Alive
If-Modified-Since: Mon, 07 Jun 2010 06:45:23 GMT
Host: serveris

HTTP/1.1 200 OK
Cache-Control: private, max-age=0
Content-Length: 114839
Content-Type: text/html; charset=utf-8
Expires: Sun, 23 May 2010 08:41:49 GMT
Last-Modified: Mon, 07 Jun 2010 08:41:49 GMT
Server: Microsoft-IIS/6.0
MicrosoftSharePointTeamServices: 12.0.0.6520
X-Powered-By: ASP.NET
X-AspNet-Version: 2.0.50727
Set-Cookie: WSS_KeepSessionAuthenticated=80; path=/
Set-Cookie: MSOWebPartPage_AnonymousAccessCookie=80; expires=Mon, 07-Jun-2010 09:11:49 GMT; path=/
Set-Cookie: ASP.NET_SessionId=d2r5lj32dm4svg554sixwc2t; path=/; HttpOnly
Date: Mon, 07 Jun 2010 08:41:51 GMT

------------------------------------------------------------------

Chrome

But when trying to use Google Chrome, then fiddler hangs if i do not close chrome soon after sending request - all i see in fiddler is a flood (thousands) of 401 (unauthorized) responses.

The question

Similar question has been asked but there is no response and i`m trying to access page without SSL and that happens even on GET requests.

Where do I look? Where would be the problem? Browser? OS? I don't even know what to think about.

Just a note

Just a note about chrome's process isolation: I found it sad that while I was waiting that minute with Chrome, i could not use any other tab (i could switch, but i could not, for example, scroll or use any controls)

share|improve this question
    
have you disabled all add-ins? –  Knox Jun 1 '10 at 11:56
    
Just tried disabling addons but that does not help. –  Janis Veinbergs Jun 1 '10 at 12:53

2 Answers 2

up vote 2 down vote accepted

As it turns out it had to do something with authentication.

I checked what is my authentication privider and i had (probably accidentally) set it to Kerberos. I changed it back to NTLM (what i'v suspected it would be) and now it works.

share|improve this answer

A shot in the dark, but I wonder if IIS is correctly setting the Content-Length header. The only way a browser really knows that it got all the data is to look at the Content-Length header, and read that many bytes, or it can read data and then timeout waiting for more. And that one minute time sort of sounds like a timeout.

Maybe the Content-Length header isn't taking compression into account and is wrong???

Try running Fiddler in IE and see what it shows.

share|improve this answer
    
I`m not on site currenly, but I tried to VPN in my workplace (that is an internal site) and i tried opening my sharepoint site - it works very well (on IE and Chrome). I will have to see if problem has auto-resolved or will i still have problems when i`ll try to open that web on site. –  Janis Veinbergs Jun 3 '10 at 9:35
    
Now i`m on site, and it still does not work. It did work with VPN from my home, but not here. Could you see edited answer please? Added fiddler logs. Also take a note that when using Chrome with fiddler, my fiddler hanged as it got flooded with 401 (unauthorized) responses. –  Janis Veinbergs Jun 7 '10 at 9:07
    
Answer/workaround found, thanks for assistance. –  Janis Veinbergs Jun 7 '10 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.