Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

since configuring a Windows Web Server 2008 R2 x64 to be hardened for an internet-facing deployment I receive this:

"Device Manager is running in read-only mode because you are running it on a remote computer."

when entering Device Manager.

I have tried reversing the changes I have made, such as:

  • Re-adding Client for Microsoft Networks
  • Re-enabling NetBIOS over TCP-IP
  • Re-adding File and Printer Sharing
  • Disabling the Windows Firewall in all profiles (public, domain, private)

I get no joy. It looks like a Microsoft ballsup. I'll try and use Process Monitor to have a look. Google returns only 1 page for this error.

Luke

share|improve this question
    
What is a "Microsoft ballsup"? Hopefully not a dig at Windows for doing what you asked it to do. –  joeqwerty Jun 1 '10 at 22:48
    
I can smell a bug after 13 years. It has oddly picked up the host name of my other test server! Computer name = x Host name in IPconfig = y (WTF!?) –  Luke Puplett Jun 1 '10 at 22:59

3 Answers 3

Did you harden it using the SCW? If so, you can run the SCW again to rollback the last SCW configuration that was applied.

share|improve this answer

I had the same problem. It turns out that my Hostname was two characters longer (17) than what was being displayed in the device manager (15). I shortened my Hostname to 15 characters, rebooted the host and now it works.

share|improve this answer
up vote 0 down vote accepted

Got it - thanks for your input Joe.

Somehow while switching between DHCP and static IP addresses and back again, my DHCP server dished up the IP address of my other server.

So Device Manager looks at the host name and compares it to the name on the connection. It clearly uses Hostname for one and the local machine name for the other and seeing as these had gotten messed up, they didn't match and thus I was deemed a remote connection!

I got this from looking at the Registry Monitor trace and seeing it looking in the Internet Explorer Zones database which made me wonder if it was a DNS issue - during this investigation I noticed the odd hostname.

Thanks again,

Luke

share|improve this answer
    
Glad you got it worked out. –  joeqwerty Jun 1 '10 at 23:22
    
So... how did you resolve the issue? –  Chloraphil May 2 '11 at 16:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.