Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Why does MC look like this in SSH clients (I've tried PuTTY and MindTerm) and how to fix it?

On the server side is fresh installed 64-bit Ubuntu 10.04 Server. On the client side is XP SP3.

share|improve this question

3 Answers 3

It's a character set mismatch. Why don't you just use WinSCP?

share|improve this answer
    
WinSCP (a pure SCP/SFTP client) and PuTTY (a full-featured SSH client) do quite different things, although the underlying protocol is the same. –  joschi Jun 2 '10 at 6:39
    
@joschi, I'm well aware they do different things, as I use them both every day. I was suggesting WinSCP as an alternative to MC, not PuTTY. I'd have thought that was obvious from the context. –  John Gardeniers Jun 2 '10 at 11:48
1  
John, Midnight Commander and WinSCP also have vastly different use cases and are usually not interchangeable. –  joschi Jun 2 '10 at 11:57
    
To those who feel an urge to downvote this answer I can only say that you have clearly not discovered just how effective a file manager WinSCP really is. –  John Gardeniers Oct 14 '10 at 1:52

This has been addressed (putty specifically) on superuser: http://superuser.com/questions/75088/putty-correct-translation-on-ubuntu-8-04

share|improve this answer
up vote 3 down vote accepted

I've found the exact answer here:

After some experimentation it turns out that to fix it all you have to do is change your character set in PuTTY to UTF-8 and the problem is fixed. To do this open up the PuTTY settings and go to Window->Translation->Received data assumed to be in which character set: and change it to UTF-8.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.