Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a kickstart file (ks.cfg) on a floppy (Old style). I am trying to install CentOS 5.4.

The top of my ks.cfg says this:

install

# Install from local cdrom or over the network.
#cdrom
url --url http://kickstart.example.org/pub/centos/5.4/

On the Apache server side, this command is failing with these 404s:

kickstart.example.org 192.168.16.180 - - [01/Jun/2010:17:24:30 -0700] "GET /pub/centos/5.4///disc1/.discinfo HTTP/1.1" 404 314 "-" "urlgrabber/3.1.0"
kickstart.example.org 192.168.16.180 - - [01/Jun/2010:17:24:43 -0700] "GET /pub/centos/5.4/repodata/repomd.xml HTTP/1.1" 404 316 "-" "urlgrabber/3.1.0 yum/3.2.22"

It seems that the value of my url doesn't match the directory structure on the server, but this is an exact mirror of the CentOS mirrors.

What should the value of url URL be? Should this only include the OS (/pub/centos/5.4/), or should it include the architecture (/pub/centos/5.4/os/x86_64 )? Can this be a variable (/pub/centos/5.4/os/$ARCH/)?

I see that Kickstart is trying to grab a file called 'repomd.xml', but why is it looking in '/pub/centos/5.4/repodata/repomd.xml', when these files actually exist at '/pub/centos/5.4/os/x86_64/repodata/repomd.xml' and other locations at '/pub/centos/5.4/*/$ARCH/repodata/repomd.xml'?

I don't see this documented or explained well in the RedHat 5 Installation Guide

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I have a 5.3 and 5.4 serving on a custom ks.cfg file. My line looks like this:

url --url http://long-path-to-your-distro/x86_64/5.3 -- or 5.4 -- no trailing slash, but it shouldn't matter.

and in there I have:

./
../
CentOS/
config/
EULA
GPL
images/
isolinux/
NOTES/
repodata/
RPM-GPG-KEY-beta
RPM-GPG-KEY-CentOS-5
TRANS.TBL
share|improve this answer
    
thanks for upvoting the answer. BTW, I just put out my notes on doing pxe boot for 5.4 Centos. They might help: notagrouch.com/linux/centos-54-pxe-boot.html –  Oscar Gonzalez Jun 7 '10 at 17:14

You should point it at the path that contains the .discinfo file and/or the repodata/ directory.

share|improve this answer
    
So I need to set something like 'url --url mirrors.kernel.org/centos/5.4/os/x86_64/'; instead of 'url --url mirrors.kernel.org/centos/5.4/';? –  Stefan Lasiewski Jun 2 '10 at 22:06
    
If that's where .discinfo and repodata/ are located, then yes. –  Ignacio Vazquez-Abrams Jun 2 '10 at 23:23
    
This works, but I wish the '--url' flag was explained better somewhere. –  Stefan Lasiewski Jun 3 '10 at 4:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.