Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

we sometimes receive Http 400 bad request resultcodes when posting a large file (10mb) to a WCF service hosted in IIS 6. We can reproduce this using SOAP UI and it seems that it is unpredictable when this happens. In our WCF log the call is not received, so we believe that the request does not reach the ASP.NET nor WCF runtime. This happens on multiple websites on the same machine each having their own application pool. All IIS settings are default, only in ASP.NET and WCF we allow bigger readerQuota's etc....

The win32status that is logged in the IIS log is 1450 which we think means "error no system resources".

So now the question: a) how can we solve this b) (when a is not applicable :) ) which performance counters or logs are usefull to learn more about this problem?

greetings, Tim

share|improve this question

1 Answer 1

check this articles KB810957 which explains the cause of the issue and UploadReadAheadSize is the solution for the same.

Let me know if that helps.

share|improve this answer
    
yes we already read this, but I would think that if this setting is set too low that every request should fail... –  Tim Mahy Jun 2 '10 at 12:52
    
if you upload the file thats larger than 4.8KB will fail. Have you also checked stackoverflow.com/questions/325275/… for WCF specific setting –  Vivek Kumbhar Jun 2 '10 at 13:06
    
yes indeed, but it only fails "sometimes", so this setting is not blocking us for every request, the WCF settings is known to us but not solving the problem –  Tim Mahy Jun 2 '10 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.