Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having a frustrating problem with one of our clients who is running an exchange SMTP server.

I have an emailing component that is written in .net and I've specifically used Mono DLL's to ensure that the email component sends the ELO and QUIT command for each message it sends.

Each mail I send will never exceed 10MB's including attachments, which is lower than the session size value set in the clients exchange configuration.

Still the problem persists. Any ideas where to look?

share|improve this question
    
I am having the same problem :( –  Josh Stodola Jul 13 '10 at 17:01

2 Answers 2

Any file attachments will grow by a significant percentage when encoded into base64, so make sure there's at least 30% head room between file size for all attachments and max session size.

wikipedia on base64:

Thus, the actual length of MIME-compliant Base64-encoded binary data is usually about 137% of the original data length

It also Might be worthwhile running wireshark on the server or client to check the content length exactly and ensure that it's actually doing what you told it to do and disconnecting

share|improve this answer
1  
+1 for the overhead consideration. I'll check out wireshark ASAP. –  JL. Jun 2 '10 at 13:26
    
yeah i edited after some fact checking, seems its closer to 30-40%. –  Aaron Tate Jun 2 '10 at 13:29

How many emails are you sending in a single session? Do you disconnect and reconnect for each mail? I've heard this happens if you have too many messages in one connection.

What are the email size limits on the mail server set to? Quota sizes? etc.?

And what exactly are the error messages on the logs of the Exchange server saying, if anything?

share|improve this answer
    
I'm in the process of determining this,I've also used 4 differant mailing components all having the same effect, clearly the issue is with exchange, not the mailing components. –  JL. Jun 2 '10 at 13:24
    
Actually no - it is a sense of sensless settings. Email is NOT a file sharing protocol. I have blocks on 8mb in place. –  TomTom Jun 2 '10 at 13:29
1  
We try to block out anything that is an executable, and if I'm configuring a mail server try to keep the limits to less than 10 meg. If I'm in a more draconian mood 5. Anything else, set it up on a web server or direct transfer over skype or instant messaging. But that's me. –  Bart Silverstrim Jun 2 '10 at 13:37
    
what configuration values specifically can cause this issue on exchange? What are the values I need to check for? –  JL. Jun 2 '10 at 13:49
    
@JL-depends on the version of exchange. –  Bart Silverstrim Jun 2 '10 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.