Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to find a quick way to change the background on all computers on my domain other than going to each one of them.

I have already tried gpedit.msc user configuration/administrative templates/desktop/active desktop and enabled active desktop and maped the active desktop wallpaper

share|improve this question
    
gpedit just does your local profile. You need GPMC. –  John Gardeniers Jun 2 '10 at 21:21

4 Answers 4

I've always found the Active Desktop GPO settings to be a little flaky in the past. This logon script should do it:

Dim WshShell

Set WshShell = WScript.CreateObject("Wscript.Shell")
WshShell.RegWrite "HKCU\Control Panel\Desktop\Wallpaper", mybitmap.bmp
WshShell.Run "%windir%\System32\RUNDLL32.EXE user32.dll, _
    UpdatePerUserSystemParameters", 1, False

Set WshShell = Nothing

Althernatively - if you're comfortable with creating MSI files - you could create one containing the necessary registry settings and deploy it via AD.

share|improve this answer

You can create a GPO with the setting "User Configuration\Administrative Templates\Desktop\Desktop\Desktop Wallpaper" with whatever wallpaper you want to define you just have to make sure the file you reference for the wallpaper is available to the user once they login.

One implementation solution would be to create a GPO and link it into the AD at a level where the users you want to be affected all live within then assign the GPO's security filtering to the group "Domain Users" (the default is authenticated users which will also work). You may also set the GPO Status to disable all computer settings.

share|improve this answer
    
Not sure why this was down voted but if you are just editing a local policy file with this setting (gpedit.msc), you will still have to distribute that policy to all machines and delete all the existing user profiles in order to get this to apply since it is a user based policy setting. Using a GPO is much easier, faster and better management in the long run. –  BoxerBucks Jun 2 '10 at 17:07
    
-1; the OP has already explicitly tried that and it didn't work. We're either figuring what went wrong or suggesting alternative solutions now. –  Darth Satan Jun 2 '10 at 21:17
    
@mh - With all due respect, the OP tried gpedit.msc. This is not editing a GPO, this is editing the local policy. Plus the active desktop setting they tried is not the same as the setting I suggested. Unless there are serious issues processing policies, this will work and will be an easier solution to maintain long term. –  BoxerBucks Jun 3 '10 at 1:09

The usual problem with this change is that the background image is either the wrong format, or located in a non-shared location.

share|improve this answer
    
Took care of that when I saved the image. I saved it on a drive that is on a shared drive –  StephanieTaylorAL Jun 2 '10 at 15:54
    
So whats the format? I believe it HAS to be either BMP or JPEG not JPG Hope that helps. –  Campo Jun 2 '10 at 16:42

make sure the wall paper file is in a network share that all users have access to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.