Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a domain (domain.local) that has IP Addresses in the 10.10.10.* range. In the outbound SMTP server traffic, I see the internal machine name (exchange.domain.local), and the internal ip address (

The question is, how do you remove this header from exchange, or change it to have the external machine name/ip addresses.

I am not talking about the HELO / EHLO handshake as part of the protocol.

Please help.

share|improve this question
What do you use for your external SMTP server? Is it an Exchange edge server, or something else? Are you just trying to have the e-mail headers not have any evidence of coming from the Exchange server? – Paul Kroon Jun 2 '10 at 17:10
What header exactly are you talking about? Can you post a sample? – Massimo Feb 17 '12 at 17:22

In order to change the name from INTERNAL to "valid" fqdn:

  1. Open EMC

  2. Expand "Server Configuration", navigate to "Hub Transport"

  3. At the lower section of the middle pane, double-click "Default "netbiosnameofyourserver""

  4. Adjust the proper name in the "Specify the FQDN ..."

No need to restart anything. The setting will be picked up almost instantaneously.

In regards to IP, you would need to use device that will be able to mask and replace IP in the outgoing packets Source NAT. Any decent firewall these days will do it.

share|improve this answer

You may check the Hub Transport rule, there is an option about Header replace.

share|improve this answer
It is a single-instance exchange server, that is, the exchange server serves as the entire mail subsystem. – user44755 Jun 14 '10 at 17:54
Ariel, I have been unable to find reference material regarding how to set this type of a rule up... do you have any pointers or information you could share? – user44755 Jun 16 '10 at 18:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.