Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting this error on almost all of the operations on a Windows 7 pro 32 bit machine. By operations I mean anything I do. Update a repo from subversion. Access a local IIS Site. Copy a big folder. Run an installer.and sometime if I try again. It get solved.

I think there is something wrong wit windows7 . I searched around and found posts suggesting to increase IRPStackSize value in registry I did that no Luck. I am using Microsoft Security Essentials Version: 1.0.1961.0 as my antivirus package

Once this errors starts popping up. I have to restart and then in after some random time. It starts showing up again.

Any help is appreciated. I am losing lot of my time in restarting my system or retrying again and again.

share|improve this question
    
Is your disk full? –  Bill Weiss Jun 2 '10 at 18:00
    
No, I have more then 15% space in my disk. My Page files are also not on the C: drive and I have disabled hibernation as well. –  Mohit Jun 2 '10 at 18:18
    
do you belong to an active directory domain and are you a member of many groups like 1000+ groups either nested or not? –  tony roth Jul 29 '10 at 18:45
    
No I m not I am part of like 5-10 groups only. –  Mohit Aug 7 '10 at 18:48
add comment

closed as not constructive by Dan, Scott Pack, mulaz, MDMarra, HopelessN00b Genius of network Sep 26 '12 at 23:47

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

I too get it with a service I have created. I really don't know much about it. I have seen it has something to do with the IRPStackSize (Read This Article)

share|improve this answer
add comment

I ran into this tonight and this blog post fixed my problem after changing these two values and rebooting:

http://alan.lamielle.net/2009/09/03/windows-7-nonpaged-pool-srv-error-2017

Set the following registry key to ’1′: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ’3′:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

I also noticed that we both have Security Essentials installed. Not sure if that is a common thread, but it is something that could be causing the issue.

share|improve this answer
add comment

This is a typical behaviour of a server that starts lots of app compiled with Delphi.

See this.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.